Переведите, пожалуйста, текст программы паскаля в КУМИРЗадача : Разработайте алгоритм определения, является ли введённое натуральное число однозначным, двухзначным, трёхзначным или многозначным (больш?

Информатика | 10 - 11 классы

Переведите, пожалуйста, текст программы паскаля в КУМИР

Задача : Разработайте алгоритм определения, является ли введённое натуральное число однозначным, двухзначным, трёхзначным или многозначным (больше трёх знаков – это много).

Паскаль :

var

write('Введите трёхзначное положительное число : ') ;

readln(a) ;

if (a999) then write('Это не трёхзначное число.

Перезапустите программу!

') else Begin

sum : = a mod 10 + a div 10 mod 10 + a div 100 ;

pro : = a mod 10 * a div 10 mod 10 * a div 100 ;

if (sum>9) and (sum99) and (pro.

Ответить на вопрос
Ответы (1)
Ivnase 15 нояб. 2020 г., 18:04:29

Алг

нач цел a, sum, pro вывод 'Введите трёхзначное положительное число : ' ввод a если a999 то вывод 'Это не трёхзначное число.

Перезапустите программу!

' иначе sum : = mod(a, 10) + mod(div(a, 10), 10) + div(a, 100) pro : = mod(a, 10) * mod(div(a, 10), 10) * div(a, 100) если sum > 9 и sum < 100 то вывод 'Сумма цифр числа ', a, ' - двухзначное число (', sum, ')', нс иначе вывод 'Сумма цифр числа ', a, ' - не двухзначное число (', sum, ')', нс все если pro > 99 и pro < 1000 то вывод 'Произведение цифр числа ', a, ' - трёхзначное число (', pro, ')', нс иначе вывод 'Произведение цифр числа ', a, ' - не трёхзначное число (', pro, ')', нс все если mod(sum, 3) = 0 то вывод 'Эта же сумма (', sum, ') кратна трём', нс иначе вывод 'Эта сумма (', sum, ') не кратна трём', нс все все

кон.

Manyuny 26 мар. 2020 г., 03:31:54 | 10 - 11 классы

Работаем с паскаль, помогите вычислить устно : a : = 75 mod 5 б)b : = 97 div 9 в)c : = 13 mod 7 г)kl : = (50 div 4) mod 5 д) fl : = 82 mod (30 div 7)?

Работаем с паскаль, помогите вычислить устно : a : = 75 mod 5 б)b : = 97 div 9 в)c : = 13 mod 7 г)kl : = (50 div 4) mod 5 д) fl : = 82 mod (30 div 7).

BGrygorenko 24 апр. 2020 г., 03:14:36 | 5 - 9 классы

Язык программирования Паскаль Вычислить 27 div 4 27 mod 4 - 7 div 2 - 7 mod 2 - 14 div 3 - 14 mod 3?

Язык программирования Паскаль Вычислить 27 div 4 27 mod 4 - 7 div 2 - 7 mod 2 - 14 div 3 - 14 mod 3.

Vip93miha 17 нояб. 2020 г., 10:43:52 | 5 - 9 классы

Чему будет равно значение переменной с в результате выполнения фрагмента программы а : = 125 ; b : = 25 ; с : = 12 ; if a div 25 = 0 then if a mod 12 = 0 then?

Чему будет равно значение переменной с в результате выполнения фрагмента программы а : = 125 ; b : = 25 ; с : = 12 ; if a div 25 = 0 then if a mod 12 = 0 then.

C : = b div (a mod c) else c : = a div (b mod c) 1) 0 ; 2) 1 ; 3) 12 ; 4) 125.

Алрпвиыд 8 сент. 2020 г., 09:21:35 | 5 - 9 классы

Что такое div и mod в информатике и как их использовать в программе КуМир?

Что такое div и mod в информатике и как их использовать в программе КуМир?

Ledidi457 17 дек. 2020 г., 00:01:23 | 5 - 9 классы

Выполняется ли равенство :(264 mod 100) div 10 = (368 div 10) mod 10?

Выполняется ли равенство :

(264 mod 100) div 10 = (368 div 10) mod 10.

Salimauitkdai 6 янв. 2020 г., 14:44:07 | 5 - 9 классы

Исходное данное - целое трёхзначное число x?

Исходное данное - целое трёхзначное число x.

Выполните для x = 125 следующий алгоритм.

A : = x div 100 b : = x mod 100 div 10 c : = x mod 10 s : = a + b + c.

Чем является результат S этого алгоритма?

E97M 13 дек. 2020 г., 23:59:56 | 5 - 9 классы

5 * 7 div 2 mod 7?

5 * 7 div 2 mod 7.

0 = - 7 mod 10 + 16 div 2 / 5 =

23 mod 0 * 5div 3 =

12 / 2 mod 5 + 12 div 2 =

40 / (10 div 2) + 8 mod 3 =

12 div 4 - 20 mod 4 =.

Perehoghina01 16 июн. 2020 г., 00:48:43 | 10 - 11 классы

Получить случайное трехзначное число и вывести через запятую все его отдельные цифры?

Получить случайное трехзначное число и вывести через запятую все его отдельные цифры.

Сделать для программы Паскаль!

Без mod и div.

Teckutiew1 8 янв. 2020 г., 11:23:42 | 5 - 9 классы

Исходное данное целое трёхзначное число для х выполните для х = 125 следующий алгоритм a : = x div 100 b : = x mod 100 div 10 c : = x mod 10 s : = a + d + c?

Исходное данное целое трёхзначное число для х выполните для х = 125 следующий алгоритм a : = x div 100 b : = x mod 100 div 10 c : = x mod 10 s : = a + d + c.

Fazipan 21 нояб. 2020 г., 18:51:38 | 10 - 11 классы

Что означает div и mod в паскале?

Что означает div и mod в паскале?

Если вам необходимо получить ответ на вопрос Переведите, пожалуйста, текст программы паскаля в КУМИРЗадача : Разработайте алгоритм определения, является ли введённое натуральное число однозначным, двухзначным, трёхзначным или многозначным (больш?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.