Сделать блок - схему для задачи?

Информатика | 5 - 9 классы

Сделать блок - схему для задачи.

Ладья и Пешка.

Даны позиции на шахматной доске так, как это принято в шахматной нотации.

Определить , бьёт ли ладья пешку.

Ответить на вопрос
Ответы (1)
Egoryshka1980 16 нояб. 2020 г., 09:39:48

/ / PascalABC.

Net 3.

2 / / Реализация

begin

var s1 : = readstring('Введите координаты ладьи : ') ;

var s2 : = readstring('Введите координаты пешки : ') ;

write ((s1[1] = s2[1]) or (s1[2] = s2[2])) ;

end.

Алгоритмический язык

нач

ввод (координаты ладьи и пешки)

Если параллель, на которой стоит ладья = параллели, на которой стоит пешка ∨ (ИЛИ) горизонталь, на которой стоит ладья = горизонтали, на которой стоит пешка

то : вывод (БЬЕТ)

иначе : вывод (НЕ БЬЕТ)

кон.

{здесь я использовал дизъюнкцию}.

КэтКэтсон 10 нояб. 2020 г., 08:28:19 | 5 - 9 классы

Шахматная доска состоит 8 столбцов и 8 строк?

Шахматная доска состоит 8 столбцов и 8 строк.

Какое минимальное количество бит потребуется для кодирования координат одного шахматного поля?

Ntn554 29 мар. 2020 г., 04:41:08 | 5 - 9 классы

Шахматная доска состоит 8 столбцов и 8 строк?

Шахматная доска состоит 8 столбцов и 8 строк.

Какое минимальное количество бит потребуется для кодирование координат одного шахматного поля.

Igorr1981 24 апр. 2020 г., 04:13:54 | 5 - 9 классы

Шахматная доска состоит 8 столбцов и 8 строк?

Шахматная доска состоит 8 столбцов и 8 строк.

Какое минимальное количество бит потребуется для кодирования координат одного шахматного поля?

Ум111 14 мар. 2020 г., 04:38:52 | 10 - 11 классы

Шахматная ладья ходит по горизонтали или вертикали?

Шахматная ладья ходит по горизонтали или вертикали.

Даны две различные клетки шахматной доски, определите, может ли ладья попасть с первой клетки на вторую одним ходом.

Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки.

Программа должна вывести YES, если из первой клетки ходом ладьи можно попасть во вторую или NO в противном случае.

Dianka1865 8 янв. 2020 г., 14:29:07 | 1 - 4 классы

Шахматный король бьёт все клетки, которые стоят рядом с ним?

Шахматный король бьёт все клетки, которые стоят рядом с ним.

Какое наименьшее кол - во шахматных королей можно поставить на кл.

Доску 5×5 так, чтобы они были все незанятые клетки доски?

Покажите , как следует расставить королей и обоснуйте, почему меньшим кол - вом королей не обойтись.

Умняшка002 14 апр. 2020 г., 13:15:41 | 5 - 9 классы

На доске 10 x 10 стоит 5 ладей, никакие две из которых не бьют друг друга?

На доске 10 x 10 стоит 5 ладей, никакие две из которых не бьют друг друга.

Сколькими способами на эту доску можно добавить еще две ладьи так, чтобы никакие две ладьи на доске не били друг друга (расстановки ладей отличаются друг от друга только в случае, если отличается набор клеток, которые эти ладьи занимают)?

0123qwerty3210 16 июл. 2020 г., 07:42:11 | 5 - 9 классы

Шахматная доска состоит 8 столбцов и 8 строк?

Шахматная доска состоит 8 столбцов и 8 строк.

Какое минимальное количество бит потребуется для кодирования координат одного шахматного поля?

Отож 6 июн. 2020 г., 04:28:08 | 10 - 11 классы

Дан двумерный массив размера N * N (вводится пользователем)?

Дан двумерный массив размера N * N (вводится пользователем).

Заполнить матрицу нулями и единицами так, чтобы получилась шахматная доска.

MrTVesh 27 нояб. 2020 г., 23:16:56 | 10 - 11 классы

Задача «Шахматная доска» Условие Даны два числа n и m?

Задача «Шахматная доска» Условие Даны два числа n и m.

Создайте двумерный массив размером n×m и заполните его символами ".

" и " * " в шахматном порядке.

В левом верхнем углу должна стоять точка.

Во всех задачах считывайте входные данные через input() и выводите ответ через print().

На питоне!

Мухаметзянова 19 сент. 2020 г., 07:24:04 | 5 - 9 классы

На шахматной доске в клетке (x1, y1) находится шахматный конь?

На шахматной доске в клетке (x1, y1) находится шахматный конь.

Определите, бьёт ли конь поле (x2, y2).

На вход программе даются четыре целых числа x1, y1, x2, y2 (1≤x1, y1, x2, y2≤8) — координаты двух клеток на шахматной доске рамера 8×8.

Требуется вывести 1, если поле находится под боем коня, или 0, если нет.

РЕШИТЬ В С + +.

На этой странице сайта размещен вопрос Сделать блок - схему для задачи? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.