Даны три переменные вещественного типа : A, B, C?

Информатика | 10 - 11 классы

Даны три переменные вещественного типа : A, B, C.

Если их значения

упорядочены по возрастанию, то удвоить их ; в противном случае заменить

значение каждой переменной на противоположное.

Вывести новые значения

переменных A, B, C.

Как решить данный пример используя только тернарный оператор?

Ответить на вопрос
Ответы (1)
Миёнька 19 авг. 2021 г., 20:18:54

Var a, b, c : real ;

begin

write('Введите A, B и C : ') ;

readln(a, b, c) ;

if (b < c) and (a < b) then

begin

a : = 2 * a ; b : = 2 * b ;

c : = 2 * c ;

end

else

begin

a : = - a ;

b : = - b ;

c : = - c ;

end ;

writeln(a, ' ', b, ' ', c) ;

end.

Marshmeloy 31 янв. 2021 г., 21:07:05 | 5 - 9 классы

Как вывести на экран значение переменной но так чтоб её значение было слово которое присвоит себе переменная в дальнейшем?

Как вывести на экран значение переменной но так чтоб её значение было слово которое присвоит себе переменная в дальнейшем.

Shibenkova 1 мар. 2021 г., 22:53:30 | 5 - 9 классы

Задача : Даны переменные А и В?

Задача : Даны переменные А и В.

Требуется обменять их значениями, т.

Е. переменная А должна получить значение В, а В - значение А.

Holi2 8 сент. 2021 г., 15:50:08 | 5 - 9 классы

Даны две переменные вещественного типа : A, B?

Даны две переменные вещественного типа : A, B.

Перераспределить значе -

ния данных переменных так, чтобы в A оказалось меньшее из значений,

а в B — большее.

Вывести новые значения переменных A и B.

(Напишите в виде блок - схемы , как - нибудь : ).

Прост в Паскале знаю как , а в виде блок - схемы трудно немного).

Maslovanv42 19 авг. 2021 г., 11:44:47 | 5 - 9 классы

Даны 3 переменные, составить программу : если все они = ; выдает сообщение : переменные = , в противном случае каждую из них увеличь на 10?

Даны 3 переменные, составить программу : если все они = ; выдает сообщение : переменные = , в противном случае каждую из них увеличь на 10.

Kolyach 13 нояб. 2021 г., 12:55:48 | 10 - 11 классы

Даны две различные переменные?

Даны две различные переменные.

Составить алгоритм, который значение меньшей переменной заменит произведением этих переменных, а значение большей - суммой.

(в ABC Pascal).

Nikitkakramoro 31 авг. 2021 г., 08:38:59 | 5 - 9 классы

Даны две переменные m и n?

Даны две переменные m и n.

Переменным присвоены начальные значения : m : = 2, n : = 7

Создать алгоритм для обмена значениями данных переменных.

В результате работы алгоритма переменная m должна иметь значение 7, а переменная n должна иметь значение 2.

Celitra19 3 сент. 2021 г., 05:58:27 | 5 - 9 классы

Переделите значение переменной с после исполнения данного алгоритма?

Переделите значение переменной с после исполнения данного алгоритма.

Символ обозначает оператор присваивания.

Kristinak199819 13 июл. 2021 г., 10:56:05 | студенческий

Даны две переменные вещественного типа : A, B?

Даны две переменные вещественного типа : A, B.

Перераспределить значения данных переменных так, чтобы в A оказалось меньшее из значений, а в B — большее.

Вывести новые значения переменных A и B в решит в VBA.

Dashatkachenko02 4 авг. 2021 г., 23:42:16 | 10 - 11 классы

Даны 2 переменные А и В?

Даны 2 переменные А и В.

Если A>B, то вывести на печать их произведение, в противном случае сумму.

Jenna1799 10 нояб. 2021 г., 00:49:32 | студенческий

Помощь по VBA ?

Помощь по VBA !

Даны две переменные вещественного типа : A, B.

Перераспределить значения данных переменных так, чтобы в A оказалось меньшее из значений, а в B — большее.

Вывести новые значения переменных A и B.

Вы перешли к вопросу Даны три переменные вещественного типа : A, B, C?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.