Написать программу в ПАСКАЛЕ которая будет с помощью массива записывать числа введенные пользователем ⇒ оставлять только те, которые кратны 8(?

Информатика | 5 - 9 классы

Написать программу в ПАСКАЛЕ которая будет с помощью массива записывать числа введенные пользователем ⇒ оставлять только те, которые кратны 8(!

)⇒ считать их среднее арифметическое.

Максимальное число чисел - 100.

Ввод чисел заканчивается числом 0.

Ответить на вопрос
Ответы (1)
Sasik845 10 июн. 2021 г., 16:40:50

Program n1 ;

const n = 100 ;

var a : array [1.

N] of integer ;

i, k, sum, temp : integer ;

begin

sum : = 0 ;

k : = 0 ;

for i : = 1 to n do

begin

write('введите ', i, ' элемент : ') ;

readln(temp) ;

if temp = 0 then break ;

if temp mod 8 = 0 then

begin a[i] : = temp ; k : = k + 1 ; sum : = sum + a[i] ;

end ;

end ;

writeln('ср.

Ариф : ', sum / k) ;

end.

StarsTrino2814 19 апр. 2021 г., 03:22:54 | 5 - 9 классы

Помогите пожалуйста с Паскалем?

Помогите пожалуйста с Паскалем.

Вводится 15 последовательных чисел, найти среднее арифметическое четнвх чисел, кратных трем из введенных Составьте полную программу.

Svetlana516298 23 янв. 2021 г., 04:11:51 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0 - признак окончания ввода, не входит в последовательность СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ.

Creeper82 25 февр. 2021 г., 07:58:12 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0 - признак окончания ввода, не входит в последовательность СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ.

ОЧЕНЬ СРОЧНО.

DariyaP 2 авг. 2021 г., 14:44:31 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0 - признак окончания ввода, не входит в последовательность

СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ.

Идиот8 18 мая 2021 г., 02:43:46 | 5 - 9 классы

Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3?

Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3.

Программа получает на выход целые числа.

Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность ).

Количество чисел не превышает 20.

Введенные числа [ - 30 ; 30].

Программа должна вывести одно число : количество четных чисел, кратных 3.

Желательно с массивом в начале.

Буду признательна!

Мтчеларрпар 4 окт. 2021 г., 04:07:52 | 5 - 9 классы

Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3?

Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3.

Программа получает на выход целые числа.

Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность ).

Количество чисел не превышает 20.

Введенные числа [ - 30 ; 30].

Программа должна вывести одно число : количество четных чисел, кратных 3.

Буду признательна!

PROST100MAG 23 июн. 2021 г., 08:37:19 | 10 - 11 классы

1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел , кратных 6?

1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел , кратных 6.

Программа получает на вод натуральные числа, кол - во введенных чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность).

Программа должна вывести одно число : сумма четырехзначных чисел , кратных 6.

2) Напишите программу , которая в последовательности натуральных чисел определяет максимальное число, кратно 3 и оканчивающиеся на 3.

Программа получает на вход кол - во чисел в последовательности, а заем сами числа.

В последовательности всегда имеется число, кратное 3 и оканчивающиеся на 3.

Кол - во чисел не превышает 1000.

Введенные числа не превышают 30 000.

Программа должна вывести одно число - максимальное число, кратное 3 и оканчивающиеся на 3.

Киря22811 25 февр. 2021 г., 13:42:05 | 5 - 9 классы

Напиши программу, которая выводит наименьший элементвведенного с клавиатуры одномерного массива целых положи -тельных чисел?

Напиши программу, которая выводит наименьший элемент

введенного с клавиатуры одномерного массива целых положи -

тельных чисел.

Если пользователь будет вводить число 0, про -

грамма должна потребовать ввести число еще раз.

C#.

Kirill221102 24 дек. 2021 г., 17:04:58 | 10 - 11 классы

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3?

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3.

Программа получает на вход целые числа.

Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

Программа должна вывести одно число : количество четных чисел, кратных 3.

KrytoiTawer 14 дек. 2021 г., 04:49:35 | 5 - 9 классы

Нужно создать программу в visual basic , она должна вычислить среднее арифметическое введенных чисел , написать программу, которая вводит с клавиатуры N вещественных чисел и вычисляет их среднее арифм?

Нужно создать программу в visual basic , она должна вычислить среднее арифметическое введенных чисел , написать программу, которая вводит с клавиатуры N вещественных чисел и вычисляет их среднее арифметическое.

После того как среднее арифметическое будет найдено программа должна начаться с начала , так же нужно что бы в числе было не больше двух чисел после запятой.

Вы зашли на страницу вопроса Написать программу в ПАСКАЛЕ которая будет с помощью массива записывать числа введенные пользователем ⇒ оставлять только те, которые кратны 8(?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.