Необходима Программа на языке Паскаль В классе проведено тестирование?

Информатика | 5 - 9 классы

Необходима Программа на языке Паскаль В классе проведено тестирование.

Максимально можно было набрать 100 баллов.

Известны баллы, набранные каждым из учеников.

Определите, сколько учеников в классе набрали : Баллы, отклоняющиеся от среднего значения не более чем на 10%.

Ответить на вопрос
Ответы (1)
Olgavorobi 19 дек. 2020 г., 20:37:15

Var a : array[1.

100] of real ;

i, k, n : integer ;

sr, pr, s : real ;

begin

write('Введите кол - во учеников в классе : ') ; readln(n) ;

writeln('Введите баллы учеников : ') ;

for i : = 1 to n do

read(a[i]) ;

s : = 0 ;

for i : = 1 to n do

s : = s + a[i] ;

sr : = s / n ; pr : = sr / 10 ;

for i : = 1 to n do

if (a[i]< ; sr + pr) and (a[i]> ; sr - pr) then

inc(k) ;

writeln('Кол - во баллов, отклоняющиеся от срзнач.

Не более чем на 10% : ', k) ;

end.

Зошит 14 нояб. 2020 г., 09:48:41 | 10 - 11 классы

10 учеников проходили тестирование 5 темам какого - либо предмета?

10 учеников проходили тестирование 5 темам какого - либо предмета.

Вычислить суммарный (по всем темам)средний балл, полученный учениками.

Сколько учеников имеют суммарный балл ниже среднего (excel).

Svetaokhapkina 10 мар. 2020 г., 19:57:36 | 5 - 9 классы

На соревнованиях по спортивному ориентированию участник должен пробежать от старта до финиша набрать максимальное возможное количество баллов какое наибольшее число баллов может набрать спортсмен?

На соревнованиях по спортивному ориентированию участник должен пробежать от старта до финиша набрать максимальное возможное количество баллов какое наибольшее число баллов может набрать спортсмен.

ZhenyoKKK 29 июн. 2020 г., 02:52:45 | 5 - 9 классы

10 учеников проходили тестирование по 5 темам какого либо предмета?

10 учеников проходили тестирование по 5 темам какого либо предмета.

Вычислить суммарный(по всем темам)средний балл, полученный учениками.

Сколько учеников имеют суммарный балл ниже среднего ?

Vasilyevayulia 9 сент. 2020 г., 23:59:33 | 5 - 9 классы

10 учеников проходили тестирование 5 темам какого - либо предмета?

10 учеников проходили тестирование 5 темам какого - либо предмета.

Вычислить суммарный (по всем темам)средний балл, полученный учениками.

Сколько учеников имеют суммарный балл ниже среднего (excel).

Алина1119 10 сент. 2020 г., 01:10:35 | 10 - 11 классы

ЕГЭ сдавали 64 ученика?

ЕГЭ сдавали 64 ученика.

Максимальный бал, который можно было получить во время экзамена - 100.

Набранный бал(число, а не цифра) каждого ученика был закодирован с использованием двоичного кода минимально возможным количеством бит, равных для всех.

Определите информационный объем сообщения, содержащего набранные баллы каждого ученика.

Gadzhieva 9 апр. 2020 г., 05:46:56 | 5 - 9 классы

Помогите набрать текст задание в описании , даю 45 баллов?

Помогите набрать текст задание в описании , даю 45 баллов.

Спорт11 20 окт. 2020 г., 06:21:07 | 5 - 9 классы

Помогите?

Помогите!

Программирование циклических структур : 1.

Известны оценки по информатике каждого ученика в классе.

Определите средний балл.

16Вадим16 8 мар. 2020 г., 18:24:57 | 10 - 11 классы

С клавиатуру набраны случайным образом 3 числа?

С клавиатуру набраны случайным образом 3 числа.

Составить программу вычисления максимального из набранных чисел.

Masha131 29 апр. 2020 г., 18:57:42 | 5 - 9 классы

Python Известны оценки по алгебре каждого ученика класса?

Python Известны оценки по алгебре каждого ученика класса.

Определить среднюю оценку.

Dfczcat 18 дек. 2020 г., 02:03:18 | 10 - 11 классы

За один семестр студент должен пройти 2 тестирования?

За один семестр студент должен пройти 2 тестирования.

Максимальное количество баллов ; которое может набрать студент за каждое тестирование, это 100 баллов.

Сообщение о том, что он прошел первое тестирование, несет 2 бита информации.

А сообщение о том, что он прошел второе тестирование, несет 1 бит информации.

Сколько баллов набрал студент в сумме за два тестирования?

На этой странице находится ответ на вопрос Необходима Программа на языке Паскаль В классе проведено тестирование?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.