Дан массив В, содержащий 12 элементов целого типа, образуют ли 8 последних элементов этого массива возрастающую последовательность?

Информатика | 5 - 9 классы

Дан массив В, содержащий 12 элементов целого типа, образуют ли 8 последних элементов этого массива возрастающую последовательность?

Если нет – вывести индекс элемента, на котором она заканчивается.

Очень срочно нужно!

Ответить на вопрос
Ответы (1)
Astyaa 13 окт. 2020 г., 03:06:32

Const n = 12 ;

var b : array[1.

N] of integer ; i, k : integer ;

begin Randomize ; Write('Последовательность : ') ; for i : = 1 to n do begin b[i] : = Random(41) + 10 ; Write(b[i], ' ') end ; Writeln ; k : = 5 ; for i : = 6 to n do if b[i]> ; b[i - 1] then k : = i else break ; if k = n then Writeln('Последние 8 элементов в возрастающей последовательности') else if k> ; 5 then Writeln('Возрастание элементов идет с номера 5 по ', k) else Writeln('Следующий за пятым элемент не возрастает')

end.

Пример

Последовательность : 44 10 33 40 15 33 45 26 43 45 49 48

Возрастание элементов идет с номера 5 по 7.

Kolotovkinayul 9 янв. 2020 г., 08:06:20 | 10 - 11 классы

Написать программу дан массив целых чисел состоящий из 20 элементов?

Написать программу дан массив целых чисел состоящий из 20 элементов.

Вывести индексы тех элементов значения которых больше заданного числа а.

Ghjkknbbv 21 дек. 2020 г., 09:04:39 | 1 - 4 классы

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами?

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами.

Требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

Ulia026 12 мар. 2020 г., 22:54:59 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста.

Срочно нужно.

Дан одномерный массив, состоящий из 10 элементов.

Вывести на экран в строчку.

Поменять местами значения от 6 - 10 элементов массива элементов массива и снова вывести на экран!

Risha88 8 мая 2020 г., 22:23:56 | 5 - 9 классы

Кто решит задачу?

Кто решит задачу?

Дан массив из N целых чисел.

Написать программу, определяющую, есть ли в массиве два соседних положительных элемента.

Если есть, то вывести индекс первого элемента, входящего в первую пару.

Petrusina42 5 июл. 2020 г., 19:55:08 | 10 - 11 классы

Объявить массив размерностью N?

Объявить массив размерностью N.

Заполнить элементы массива.

Распечатать значения элементов массива.

Вывести значения в обратном порядке.

Вывести значения элементов с четными индексами.

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Мистер00 21 янв. 2020 г., 03:12:38 | 5 - 9 классы

Дан массив из тридцати элементов?

Дан массив из тридцати элементов.

Вывести индексы всех элементов, равных по значению а.

Если таких элементов нет - вывести сообщение с текстом "No solution".

Формат входных данных На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива.

На второй строке записано целое положительное число a.

Формат выходных данных Строка, содержащая искомые индексы, либо знадпись "No solution", если таковых нет.

Di333 9 апр. 2020 г., 12:07:33 | 10 - 11 классы

СРОЧНО?

СРОЧНО!

Дан массив из 15 действительных чисел определить индексы элементов массива, значение которых равно значению первого элемента массива, если такого массива нет вывести соответствующее собщение на экран.

IRINASTRELZ 27 нояб. 2020 г., 01:23:12 | 5 - 9 классы

PascalABC1)Дан массив целых чисел, состоящий из 8 элементов?

PascalABC

1)Дан массив целых чисел, состоящий из 8 элементов.

Заполнить его с клавиатуры.

Найти сумму элементов, имеющий нечётный индекс.

2)Сформировать одномерные массив из N элементов, где элементы массива - целые случайные числа.

Вывести индексы тех элементов, значение которых больше заданного числа A (A вводить с клавиатуры).

3)Определите, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Gffghvd 8 окт. 2020 г., 19:16:16 | 5 - 9 классы

Дан массив А целых чисел, состоящий из 25 элементов?

Дан массив А целых чисел, состоящий из 25 элементов.

Заполнить с клавиатуры.

3)Найти элемент массива кратный 12 и его индекс.

4)Найти сумму положительных элементов, значения которых меньше 10.

5)Вывести индексы тех элементов, которых кратн.

На этой странице находится вопрос Дан массив В, содержащий 12 элементов целого типа, образуют ли 8 последних элементов этого массива возрастающую последовательность?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.