Помогите с информатикой?

Информатика | 5 - 9 классы

Помогите с информатикой.

Дано 3 значное число.

Определить : четырехзначное число, полученное приписыванием цифры единиц в качестве цифры тысяч( например, из числа 137 необходимо получить число 7137.

Ответить на вопрос
Ответы (1)
Mihamiha 29 мая 2020 г., 23:20:16

С + +

#include < ; iostream> ;

int main()

{ int n ; std : : cin > ; > ; n ; std : : cout < ; < ; n % 10 < ; < ; n ; return 0 ;

} - - - - - - - - - - - - - - - - - - - - -

Pascal

var n : integer ;

begin readln(n) ; writeln(n mod 10, n) ;

end.

Moooro3 29 нояб. 2020 г., 01:44:13 | 10 - 11 классы

Дано натуральное четырехзначное число?

Дано натуральное четырехзначное число.

Найти число , полученное перестановкой 2 и 3 цифр заданного числа.

Maribamariba031 8 нояб. 2020 г., 14:30:12 | 5 - 9 классы

Дано целое положительное четырехзначное число?

Дано целое положительное четырехзначное число.

Напишите программу, позволяющую определить двузначное число, в котором число десятков соответствует первой цифре заданного числа, а число единиц - последней.

Например : 3234 = > ; 34.

Msahmatova 20 янв. 2020 г., 01:02:01 | 10 - 11 классы

Дано натуральное трехзначное число N?

Дано натуральное трехзначное число N.

Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч).

Vlad1956 4 июл. 2020 г., 10:21:12 | 1 - 4 классы

. Дано четырехзначное число N?

. Дано четырехзначное число N.

Определить, делится ли это число на все свои цифры?

Andreit34 23 июн. 2020 г., 22:08:07 | 5 - 9 классы

Задача 2?

Задача 2.

Дано четырехзначное число.

Найти число, полученное перестановкой второй и третьей цифры заданного числа.

(Например, 4567 - - - > ; 4657).

ЕленаВик 28 мая 2020 г., 05:43:12 | 5 - 9 классы

Задача 2?

Задача 2.

Дано четырехзначное число.

Найти число, полученное перестановкой второй и третьей цифры заданного числа.

(Например, 4567 - - - > ; 4657).

Vavdhksb 6 янв. 2020 г., 20:50:15 | 5 - 9 классы

С клавиатуры вводится четырехзначное число?

С клавиатуры вводится четырехзначное число.

Необходимо подсчитать сумму цифр этого числа.

Ааабббвввгоггг 15 нояб. 2020 г., 05:50:38 | 5 - 9 классы

Распишите, пожалуйста, подробно?

Распишите, пожалуйста, подробно.

Что именно записать Задача 1.

Используя операции div и mod, найти сумму цифр случайного трехзначного числа.

На экран должно быть выведено само число и сумма цифр этого числа.

Задача 2.

Получить четырехзначное число, полученное из случайного двузначного числа, приписыванием цифры единиц в качестве цифры тысяч, а цифры десятков – в качестве цифры сотен.

(например, из числа 32 получится число 2332).

Eralhan 14 окт. 2020 г., 03:51:57 | 5 - 9 классы

2) Вводится четырехзначное число с клавиатуры?

2) Вводится четырехзначное число с клавиатуры.

Определить цифру тысяч, сотен, десятков и единиц.

В окне вывода должно быть так (это пример)

Введи четырехзначное число :

1234

цифра тысяч - 1

цифра сотен - 2

цифра десятков - 3

цифра единиц - 4.

Denrulit2015 9 дек. 2020 г., 23:48:16 | 5 - 9 классы

Вводится четырехзначное число с клавиатуры?

Вводится четырехзначное число с клавиатуры.

Определить цифру тысяч, сотен, десятков и единиц.

В окне вывода должно быть так (это пример)

Введи четырехзначное число :

1234

цифра тысяч - 1

цифра сотен - 2

цифра десятков - 3

цифра единиц - 4.

Вы зашли на страницу вопроса Помогите с информатикой?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.