НАЙДИТЕ ОШИБКУ В КОДЕ?

Информатика | 10 - 11 классы

НАЙДИТЕ ОШИБКУ В КОДЕ!

Задание : Написать программу, которая бы рассчитывала значение выражения по формуле : (ln|cos(x)|) / (ln(1 + x ^ 2).

Мой код : Program formula ; var x : integer ; y : real ; begin write('vvedute x ') ; readln(x) ; y : = (ln(abs(cos(x)))) / ln(1 + cos(x * x)) ; writeln('y = ', y : 5 : 2) ; end.

Почему то выдаёт ошибку.

Что не так?

Ответить на вопрос
Ответы (1)
ЛеруняЛера 12 янв. 2020 г., 23:36:15

Program formula ;

var x : integer ; p, y : real ;

begin Write('vvedute x< ; > ; 0 - > ; ') ; Readln(x) ; if x = 0 then Writeln('x = 0 nedopustimo') else begin p : = abs(cos(x)) ; if p = 0 then Writeln('ln(0) v 4islitele') else begin y : = ln(p) / ln(1 + sqr(x * x)) ; Writeln('y = ', y : 5 : 2) end end

end.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Учени10101010101010 15 дек. 2020 г., 09:59:59 | 5 - 9 классы

Прошу вас, помогите?

Прошу вас, помогите!

Решается оценка!

Найдите ошибки в программе 1)Program z1 ; var a : integer ; begin a : = 10 ; while a< ; 5 do writeln(a) ; a : = a + 1 ; End.

2)Program z2 ; var a, s : integer ; begin a : = 1 ; s : = 0 ; while a< ; 10 do begin s : = s + a / 2 ; end ; writeln(s) ; end.

Йчуметнлщдшщгапм5689 22 авг. 2020 г., 00:02:41 | 5 - 9 классы

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END?

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END.

Bobskill 9 июл. 2020 г., 21:30:30 | 5 - 9 классы

Всем привет?

Всем привет.

Вообщем, вот задача и к ней необходимо написать программу(Pascal).

Код программы будет ниже.

Нужно проверить его на ошибки и дать коментарии к коду.

Если код неправильный прошу подкорректировать.

Буду очень признателен.

Заранее спасибо.

Задача : Дана последовательность из n действительных чисел (n < ; = 100).

Написать программу для подсчета суммы этих чисел.

Код программы : var massiv : array [1.

100] of real ; sum : real ; n, i : integer ; begin clrscr ; writeln ('Введите количество чисел') ; readln (n) ; for i : = 1 to n do begin writeln ('Введите ', i, ' - ое число') ; readln (massiv [i]) ; end ; sum : = 0 ; for i : = 1 to n do sum : = sum + massiv [i] ; writeln ('Сумма последовательности равна ', sum : 0 : 4) ; readln ; end.

14013 10 мая 2020 г., 01:22:45 | 10 - 11 классы

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе?

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе.

Написать тот вариант программы, который, по Вашему мнению, будет правильным.

Program My_Error ; Var X, Y, Сумма : Integer ; Begin WriteLn( Введите значение X) ; ReadLn(X) ; WriteLn( Введите значение Y) ; ReadLn(Y) ; Сумма = X + Y ; WriteLn(Сумма) End.

ArturAadamson41 2 сент. 2020 г., 00:42:09 | 5 - 9 классы

Перепишите программу исправивь ошибки : Program primer : Var : a, b = integer ; Begin ; ReadLn ( a, b) ; s = a + b ; m : a * b ; d : = a : b ; Write ( s, m, d) ; End?

Перепишите программу исправивь ошибки : Program primer : Var : a, b = integer ; Begin ; ReadLn ( a, b) ; s = a + b ; m : a * b ; d : = a : b ; Write ( s, m, d) ; End.

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Evgenistruts 24 окт. 2020 г., 14:58:35 | 5 - 9 классы

Срочно, нужно выявить ошибки?

Срочно, нужно выявить ошибки.

Program linur ; Var b, R : integer ; x : real ; Begin Write ; readln(b, R, x) ; x : = - (b / R) ; write(’Решение линейного уравнения ; x) ; end.

Sashakolesnsk2 20 дек. 2020 г., 18:01:57 | 10 - 11 классы

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3?

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3.

5 ; writeln (a) ; end.

Galina50286 13 дек. 2020 г., 16:46:22 | 5 - 9 классы

Найдите ошибки в следующих программах :Program int_r ;Var a, x : integer ;b, c : real ;Begina : = 10 ;b : = 5?

Найдите ошибки в следующих программах :

Program int_r ;

Var a, x : integer ;

b, c : real ;

Begin

a : = 10 ;

b : = 5.

2 ;

x : = b div 2 ;

c : = round(x) ;

End.

Program int_r1 ;

Var a, c : integer ;

b, d : real ;

Begin

a : = 25 ;

b : = a / 2 ;

c : = sqr(a) ;

d : = a mod 10 ;

End.

Если вам необходимо получить ответ на вопрос НАЙДИТЕ ОШИБКУ В КОДЕ?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.