Паскаль?

Информатика | 5 - 9 классы

Паскаль.

Напишите программу, которая по последней цифре числа определяет последнюю цифру квадрата этого числа.

Ответить на вопрос
Ответы (2)
Alenavorfolomeewa 10 июл. 2021 г., 15:19:56

Var a, b : longint ;

begin

write ('введите число - > ; ') ;

readln (a) ;

a : = a mod 10 ;

b : = (a * a) mod 10 ;

writeln ('последняя цифра квадрата числа - > ; ', b) ;

end.

Mdou65 10 июл. 2021 г., 15:19:57

Var i : Integer ;

begin write('Число : ') ;

readLn(i) ; i : = i mod 10 ; writeLn('Цифра квадрата = ',

sqr(i) mod 10) ;

end.

Solomnikovigor 6 февр. 2021 г., 16:08:53 | 5 - 9 классы

С клавиатуры вводится натуральное число ?

С клавиатуры вводится натуральное число .

Найдите последнюю цифру числа.

Входные данные : введите натуральное число : 371.

Выходные данные : последняя цифра 1.

Паскаль.

Пожалуйста.

Срочно.

Barbara944 2 мар. 2021 г., 03:59:12 | 5 - 9 классы

1)Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи?

1)Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи.

2)Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.

Сделайте в Паскале Pascal.

Ioannagor 6 авг. 2021 г., 09:25:46 | 5 - 9 классы

Напишите программу, которая возводит в квадрат трехзначное число, введённое с клавиатуры, при условии, что в числе содержится цифра 7?

Напишите программу, которая возводит в квадрат трехзначное число, введённое с клавиатуры, при условии, что в числе содержится цифра 7.

Если в числе нет цифры 7, то следует вывести число в исходном виде(через оператор if)Паскаль.

98ВеРоНиКа89 25 мар. 2021 г., 05:07:01 | 5 - 9 классы

Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковые цифры, стоящие рядом (как, например, 221)Желательно программу на Паскале?

Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковые цифры, стоящие рядом (как, например, 221)

Желательно программу на Паскале.

TimaVA 15 февр. 2021 г., 17:58:35 | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

ПАСКАЛЬ!

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, последняя цифра которых равна А и все число делится на В.

Последовательность чисел заканчивается числом 0.

Числа А и В вводятся до цикла.

(должен быть цикл while).

Katerina1602 25 мар. 2021 г., 07:53:24 | 10 - 11 классы

Напишите пожалуйста в Паскале программу, которая считывает целое число и определяет (выводя результат на экран), сколько цифр в этом числе равно 7?

Напишите пожалуйста в Паскале программу, которая считывает целое число и определяет (выводя результат на экран), сколько цифр в этом числе равно 7.

Max1923 7 мая 2021 г., 06:52:55 | 10 - 11 классы

Дано натуральное число n?

Дано натуральное число n.

Найти отношение последней цифры к первой цифре заданного числа.

Помогите написать программу в Паскале.

Сергей219 28 мая 2021 г., 15:55:50 | 5 - 9 классы

Составьте программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом?

Составьте программу, определяющую, является ли последняя цифра введенного целого числа нечетным числом.

Yaroslaw132003 12 нояб. 2021 г., 19:11:56 | 5 - 9 классы

Составте программу в паскале которая определяет, является ли сумма цифр введеного целого трёхзначного числа чётным числом?

Составте программу в паскале которая определяет, является ли сумма цифр введеного целого трёхзначного числа чётным числом.

NashaNatasha 22 окт. 2021 г., 08:57:50 | 5 - 9 классы

Составьте программу, определяющую, является ли последняя цифра введенного целого числа (любого) четной ли нечётной?

Составьте программу, определяющую, является ли последняя цифра введенного целого числа (любого) четной ли нечётной.

На этой странице находится вопрос Паскаль?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.