Написать программу?

Информатика | 10 - 11 классы

Написать программу.

В программу вводится n чисел, величину n задаёт пользователь, а также числа вводятся подряд.

1. Найти сумму введённых чисел.

2. Количество чисел равных 0.

3. Найти максимум и минимум среди введённых чисел.

Нужно на языке С.

Помогите пожалуйста.

Ответить на вопрос
Ответы (1)
Ilya8139 22 июл. 2021 г., 11:44:07

Крч вот на паскале, на Си не могу, сорь

program llllll ;

var

A : array [ - 1000.

1000] of integer ;

n, i, b : integer ;

begin writeln('Введите количество чисел') ; readln(n) ; b : = 0 ; for i : = 1 to n do readln(A[i]) ; for i : = 0 to (n) do b : = b + A[i] ; write('Это сумма ') ; writeln(b) ; / / Это сумма.

B : = 0 ; for i : = 1 to (n) do begin if A[i] = 0 then b : = b + 1 end ; write('Это количество нулей ') ; writeln(b) ; / / это количество нулей b : = - 1001 ; for i : = 1 to (n) do begin if A[i] > ; b then b : = A[i] end ; write('Это максимальное число ') ; writeln(b) ; / / Это максимальное число b : = 1001 ; for i : = 1 to (n) do begin if A[i] < ; b then b : = A[i] end ; write('Это минимальное число ') ; writeln(b) / / Это минимальное число

end.

Serega9797 3 янв. 2021 г., 04:45:20 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет суммы и среднего арифмитического введённых положительных чисел?

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет суммы и среднего арифмитического введённых положительных чисел.

Используйте оператор while do.

Baymax73 21 мая 2021 г., 00:20:13 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел?

Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел.

Использовать цикл repeat.

PokemonYouTube 18 авг. 2021 г., 16:12:33 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел?

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30000.

Программа должна вывести два числа : длину последовательности и сумму чётных чисел.

Sysoeva4 6 июл. 2021 г., 16:10:43 | 5 - 9 классы

Написать программу, которая определяет максимальное число из введённой последовательности положительных чиселзавершение вводом 0?

Написать программу, которая определяет максимальное число из введённой последовательности положительных чисел

завершение вводом 0.

Dasha2809 28 сент. 2021 г., 19:18:01 | 5 - 9 классы

Написать программу, которая определяет максимальное число из введённой последовательности положительных чиселзавершение вводом 0?

Написать программу, которая определяет максимальное число из введённой последовательности положительных чисел

завершение вводом 0.

Марина847 15 июн. 2021 г., 12:40:14 | 5 - 9 классы

17. Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3?

17. Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число : сумму всех однозначных чисел, кратных 3.

ДимитрийД 22 нояб. 2021 г., 07:42:08 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет количество двузначных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет количество двузначных чисел, кратных 5.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30000.

Программа должна вывести одно число : количество двузначных чисел, кратных 5.

Пожалуйста помогите!

Lezxa 9 янв. 2021 г., 05:23:17 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 2?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 2.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число : сумму всех чисел, кратных 7 и оканчивающихся на 2.

Соф11 10 дек. 2021 г., 00:09:57 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и и подсчет суммы?

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и и подсчет суммы.

Введённых положительных чисел.

Используйте оператор repeat.

Решить в паскале.

DamirMU 26 июн. 2021 г., 13:09:52 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных6 и оканчивающихся на6?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных6 и оканчивающихся на6.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает100.

Введённые числ.

На странице вопроса Написать программу? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.