ПОМОГИТЕ?

Информатика | 5 - 9 классы

ПОМОГИТЕ!

СРОЧНО НАДО!

ДАЮ 40 БАЛЛОВ!

Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и : а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом массиве хотя бы одно число, кратное трем д) находит в этом массиве индексы элементов, значения которых кратны трем .

Ответить на вопрос
Ответы (1)
Мотир 17 мар. 2021 г., 04:49:48

#include < ; stdio.

H> ; #include < ; stdlib.

H> ;

#define MAX 16

void main(void){ int i, A[MAX], TRI[MAX], ODD[MAX], null = 0, minus = 0, tre = 0, k ; for (i = 0 ; i < ; MAX ; i + + ) { if (i % 2 = = 0) { k = 1 ; A[i] = k * i ; } else { k = - 1 ; A[i] = k * i ; } } for (i = 0 ; i < ; MAX ; i + + ) { if (A[i] = = 0) null + + ; if (A[i] % 2 = = 0) { ODD[i] = A[i] ; printf("Even : %i \ n", i) ; } if (A[i] < ; 0) minus + + ; if (A[i] % 3 = = 0) { tre + + ; TRI[i] = A[i] ; printf("Del on tri = 0 : %i \ n", i) ; } }}.

SuperVadim228 20 янв. 2021 г., 09:54:00 | 5 - 9 классы

Составить программу которая формирует массив из 30 - и чисел случайным образом (числа до 100) положительные и отрицательные, которое находит меньший элемент массива?

Составить программу которая формирует массив из 30 - и чисел случайным образом (числа до 100) положительные и отрицательные, которое находит меньший элемент массива.

Римасик 17 мая 2021 г., 10:56:35 | 5 - 9 классы

Составьте программу которая заполняет массив a[1?

Составьте программу которая заполняет массив a[1.

10] случайными целыми числами в диапазоне от 1 до 20 и находится минимальный элемент массива и его индекс.

BlackEagle55555 29 янв. 2021 г., 08:01:20 | 5 - 9 классы

Ребята, помогите решить, пожалуйста))) 1) Составьте программу которая заполняет массив a[1?

Ребята, помогите решить, пожалуйста))) 1) Составьте программу которая заполняет массив a[1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит минимальный элемент массива среди элементов с нечетными индексами.

2) Составьте программу которая заполняет массив a[1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит максимальный элемент массива, а затем вычисляет, сколько раз он встречается а массиве.

Viktorohrim200 1 мая 2021 г., 23:55:53 | 5 - 9 классы

Кто разбирается?

Кто разбирается?

Короче, такая хрень, помогите пожалуйста!

Составьте программу, которая формирует массив из шестнадцати случайных целых чисел от - 20 до 20 и : а) находит элементы с нулевыми знаниями ; б) находит индексы нечетных элементов ; в) подсчитывает количество положительных элементов.

- Ну?

Кто тут умный?

Alisaisaeva 16 мая 2021 г., 22:49:51 | 5 - 9 классы

Составьте программу заполняет массив [1?

Составьте программу заполняет массив [1.

10] случайными целыми числами в диапазоне от 0 до10 и находит максимальный элемент массива среди элементов с четными индексами.

Дурдурдом 21 янв. 2021 г., 05:02:31 | 10 - 11 классы

Составьте программу, которая формирует массив из шестнадцати чисел от - 20 до 20 и находит индексы четных элементов?

Составьте программу, которая формирует массив из шестнадцати чисел от - 20 до 20 и находит индексы четных элементов.

Alli3567 18 июн. 2021 г., 12:27:05 | 10 - 11 классы

1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3?

1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3.

2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.

Oleftina2005 19 июн. 2021 г., 10:01:42 | 10 - 11 классы

Задан одномерный массив X1, X2, …, XN ?

Задан одномерный массив X1, X2, …, XN .

Фрагмент алгоритма определяет Выберите один ответ : индекс первого отрицательного элемента индекс минимального элемента массива индекс последнего отрицательного элемента минимальный элемент массива количество отрицательных элементов.

Poteriannaya 26 мар. 2021 г., 17:03:12 | 5 - 9 классы

Ребята, помогите решить, пожалуйста))) 1) Составьте программу которая заполняет массив a[1?

Ребята, помогите решить, пожалуйста))) 1) Составьте программу которая заполняет массив a[1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит минимальный элемент массива среди элементов с нечетными индексами.

2) Составьте программу которая заполняет массив a[1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит максимальный элемент массива, а затем вычисляет, сколько раз он встречается а массиве.

Mariyagurtikow 24 дек. 2021 г., 13:33:39 | 10 - 11 классы

Дан целочисленный массив из 30 элементов?

Дан целочисленный массив из 30 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Напишите программу, которая находит и выводит сумму элементов массива, кратных тринадцати или семнадцати.

Если ни одного такого числа нет, нужно вывести сообщение об этом.

Ввод массива осуществить с помощью генератора случайных чисел.

Паскаль.

На этой странице вы найдете ответ на вопрос ПОМОГИТЕ?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.