Написать программу для Pascal ABC : Программа вводит 2 строки, затем из короткой строки вывод на экран символы, код которых больше 70, а из длинной строки – все цифры?

Информатика | 5 - 9 классы

Написать программу для Pascal ABC : Программа вводит 2 строки, затем из короткой строки вывод на экран символы, код которых больше 70, а из длинной строки – все цифры.

Ответить на вопрос
Ответы (1)
DeFLyer 22 февр. 2021 г., 20:37:41

/ / PascalABC.

NET 3.

2 сборка 1318

Var s1, s2, c : string ; i : integer ;

begin

write('Type s1 : ') ;

readln(s1) ;

write('Type s2 : ') ;

readln(s2) ;

if length(s1)> ; length(s2) then begin for i : = 1 to length(s1) do if (s1[i]> ; = '0') and (s1[i]< ; = '9') then write(s1[i]) ; writeln ; for i : = 1 to length(s2) do if ord(s2[i])> ; 70 then write(s2[i]) ; end

else begin for i : = 1 to length(s1) do if ord(s1[i])> ; 70 then write(s1[i]) ; writeln ; for i : = 1 to length(s2) do if (s2[i]> ; = '0') and (s2[i]< ; = '9') then write(s2[i]) ; end ;

end.

Пример ввода :

Type s1 : Mi Zu

Type s2 : MeL10N

Пример вывода :

MiZu

10.

Supreme1604 13 мар. 2021 г., 23:46:49 | 5 - 9 классы

НАПИСАТЬ ПРОГРАММУ НА PASCAL"Дана строка символов S, состоящая максимум из 250 символов?

НАПИСАТЬ ПРОГРАММУ НА PASCAL

"Дана строка символов S, состоящая максимум из 250 символов.

Напишите программу, которая проверит является ли строка S палиндромом.

Примеры палиндромов : ‘COJOC’, ‘CAZAC’, ‘POTOP’, ‘ROTOR’.

".

Mila2483 24 июн. 2021 г., 19:39:35 | 10 - 11 классы

Напишите программу, которая вводит строку и выводит ее, сокращая каждый раз на 1 символ с начала строки до тех пор, пока в строке не останется 1 символ?

Напишите программу, которая вводит строку и выводит ее, сокращая каждый раз на 1 символ с начала строки до тех пор, пока в строке не останется 1 символ.

Balaca 25 мар. 2021 г., 13:31:20 | 5 - 9 классы

Дана строка длинной более двух символов?

Дана строка длинной более двух символов.

Написать программу, выводящую на экран строку, составленную из первого, третьего и последнего символов исходной строки.

Taranushenkoann 15 авг. 2021 г., 11:54:45 | 5 - 9 классы

Составьте программу , которая выводит на экран коды символов в слове BEBY?

Составьте программу , которая выводит на экран коды символов в слове BEBY.

ABC Pascal.

AleksandraNnn 5 июн. 2021 г., 04:44:54 | 5 - 9 классы

Составте программу , которая предлагает ввести с клавиатуры две строки s и t и выводит на экран наиболее длинную строку?

Составте программу , которая предлагает ввести с клавиатуры две строки s и t и выводит на экран наиболее длинную строку.

ВладИванчин 24 февр. 2021 г., 06:51:18 | 10 - 11 классы

Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке?

Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке.

Входные данные

На вход программы подаётся символьная строка.

Выходные данные

Программа должна вывести количество различных символов в этой строке.

Примеры

входные данные

aB122AB

выходные данные

5

Pascal ABC 1.

8.

Anika2222 23 окт. 2021 г., 05:26:11 | 10 - 11 классы

Напишите программу, которая находит все символы, встречающиеся в обеих переданных ей строках?

Напишите программу, которая находит все символы, встречающиеся в обеих переданных ей строках.

Входные данные

На вход программы подаются две символьные строки, каждая строка завершается символом "конец строки".

Выходные данные

Программа должна вывести все символы, которые встречаются в обеих строках, в порядке возрастания их ASCII - кодов.

Если таких символов нет, нужно вывести слово 'NO'.

Примеры

входные данные

qwerty

asdqwhy

выходные данные

qwy

входные данные

qwerty

12345

выходные данные

NO

Pascal ABC 1.

8 Программа должна быть составлена по теме множества.

Korovamu 25 авг. 2021 г., 07:48:52 | 10 - 11 классы

Напишите программу, которая находит все символы в символьной строке, которые встречаются только один раз?

Напишите программу, которая находит все символы в символьной строке, которые встречаются только один раз.

Входные данные

На вход программы подаётся символьная строка.

Выходные данные

Программа должна вывести все символы, которые встречаются в строке только один раз, в порядке возрастания их ASCII - кодов.

Если таких символов нет, нужно вывести слово 'NO'.

Примеры

входные данные

asd12ad2

выходные данные

1s

Pascal ABC 1.

8 с использованием множеств.

Iro4ka12 7 нояб. 2021 г., 11:26:47 | 10 - 11 классы

Написать программу, которая выводит на экран количество чисел, имеющихся в строке из различных знаков?

Написать программу, которая выводит на экран количество чисел, имеющихся в строке из различных знаков.

Nika0219 6 апр. 2021 г., 13:45:34 | студенческий

Даны две строки?

Даны две строки.

Вычеркнуть из строки A символы, не встречающиеся в строке B.

Помогите написать программу для delphi или pascal.

На этой странице сайта вы найдете ответы на вопрос Написать программу для Pascal ABC : Программа вводит 2 строки, затем из короткой строки вывод на экран символы, код которых больше 70, а из длинной строки – все цифры?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.