Записаны 2 рекурсивные функции, F и G?

Информатика | 10 - 11 классы

Записаны 2 рекурсивные функции, F и G.

Function F(n : integer) : integer ; begin if n> ; 2 then F : = F(n - 1) + G(n - 2) else F : = n ; end ; function G(n : integer) : integer ; begin if n> ; 2 then G : = G(n - 1) + F(n - 2) else G : = n + 1 ; end ;

Чему будет равно значение, вычисленное при выполнении вызова F(6)?

Ответить на вопрос
Ответы (1)
Крис5 22 мар. 2020 г., 19:31:24

Вот полная трассировка вызовов при вычислении F(6) :

Вызов F(6)

Вызов F(5)

Вызов F(4)

Вызов F(3)

Вызов F(2)

Выход из F со значением 2

Вызов G(1)

Выход из G со значением 2

Выход из F со значением 4

Вызов G(2)

Выход из G со значением 3

Выход из F со значением 7

Вызов G(3)

Вызов G(2)

Выход из G со значением 3

Вызов F(1)

Выход из F со значением 1

Выход из G со значением 4

Выход из F со значением 11

Вызов G(4)

Вызов G(3)

Вызов G(2)

Выход из G со значением 3

Вызов F(1)

Выход из F со значением 1

Выход из G со значением 4

Вызов F(2)

Выход из F со значением 2

Выход из G со значением 6

Выход из F со значением 17

17 - это ответ.

Gribaneva 19 февр. 2020 г., 20:46:42 | 10 - 11 классы

Определите, какое число будет напечатано в результате выполнения следующего алгоритма : var a, b, t, M, R : integer ; Function F(x : integer) : integer ; begin F : = 3 * (x - 8) * (x - 8) end ; begin ?

Определите, какое число будет напечатано в результате выполнения следующего алгоритма : var a, b, t, M, R : integer ; Function F(x : integer) : integer ; begin F : = 3 * (x - 8) * (x - 8) end ; begin a : = - 20 ; b : = 20 ; M : = a ; R : = F(a) ; for t : = a to b do begin if (F(t) < ; R) then begin M : = t ; R : = F(t) end end ; write(M) ; end.

Йчуметнлщдшщгапм5689 22 авг. 2020 г., 00:02:41 | 5 - 9 классы

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END?

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END.

RozenNn 15 мар. 2020 г., 11:35:54 | 10 - 11 классы

Напишите программу, которая выводит на экран значение n?

Напишите программу, которая выводит на экран значение n!

Включая следующую функцию function factorial (n : integer) : integer ; var p, i : integer ; begin p : = 1 ; for i : = 1 to n do p : = p * i ; factorial : = p ; end ;

Ангелхранител 15 дек. 2020 г., 12:23:40 | 10 - 11 классы

Function F(n : integer) : integer ; begin if n < ; 6 then F : = n + F(n + 3) * F(2 * n) else F : = 2 * n ; end ; Чему будет равно значение, вычисленное алгоритмом при выполнении вызова F(3)?

Function F(n : integer) : integer ; begin if n < ; 6 then F : = n + F(n + 3) * F(2 * n) else F : = 2 * n ; end ; Чему будет равно значение, вычисленное алгоритмом при выполнении вызова F(3)?

(С РЕШЕНИЕМ).

Schevvaleria 3 окт. 2020 г., 20:32:02 | 10 - 11 классы

EGE #11 procedure F(n : integer) ; begin if n > ; 0 then G(n - 1) ; end ; procedure G(n : integer) ; begin writeln(' * ') ; if n > ; 1 then F(n - 3) ; end ; На выходе у меня 1 " * " Правильно ли?

EGE #11 procedure F(n : integer) ; begin if n > ; 0 then G(n - 1) ; end ; procedure G(n : integer) ; begin writeln(' * ') ; if n > ; 1 then F(n - 3) ; end ; На выходе у меня 1 " * " Правильно ли?

Treio 28 авг. 2020 г., 11:10:47 | 10 - 11 классы

Помогите решить, пожалуйста) var a, b, t, M, R : integer ; Function F(x : integer) : integer ; begin F : = 9 * (x + 19) * (x - 19) + 1 ; end ; begin a : = - 20 ; b : = 20 ; M : = a ; R : = F(a) ; for ?

Помогите решить, пожалуйста) var a, b, t, M, R : integer ; Function F(x : integer) : integer ; begin F : = 9 * (x + 19) * (x - 19) + 1 ; end ; begin a : = - 20 ; b : = 20 ; M : = a ; R : = F(a) ; for t : = a to b do begin if (F(t) < ; R ) then begin M : = t ; R : = F(t) end end ; write(M) ; end.

Dascha16 8 апр. 2020 г., 09:25:32 | 10 - 11 классы

Дана рекурсивная функция : function f(n : integer) : integer ; begin if n> ; 100 then f : = n - 10 else f : = f(f(n + 11)) end ; Вычислите f(96)?

Дана рекурсивная функция : function f(n : integer) : integer ; begin if n> ; 100 then f : = n - 10 else f : = f(f(n + 11)) end ; Вычислите f(96).

Natalishubina 19 сент. 2020 г., 03:06:31 | 10 - 11 классы

Дан рекурсивный алгоритм : function F(n : integer) : integer ; begin if n < ; 5 then F : = F(n + 3) + F(2 * n) + F(3 * n div 2) else F : = n + 2 ; end ; Чему будет равно значение, вычисленное алгори?

Дан рекурсивный алгоритм : function F(n : integer) : integer ; begin if n < ; 5 then F : = F(n + 3) + F(2 * n) + F(3 * n div 2) else F : = n + 2 ; end ; Чему будет равно значение, вычисленное алгоритмом при выполнении вызова F(3)?

EKATERLINS 24 дек. 2020 г., 05:33:05 | 5 - 9 классы

Определите, какое число будет напечатано в результате выполнения следующего алгоритма : var a, b, t, N, P : integer ; Function F(x : integer) : integer ; begin F : = 16 * (9 - x) * (9 - x) + 127 ; end?

Определите, какое число будет напечатано в результате выполнения следующего алгоритма : var a, b, t, N, P : integer ; Function F(x : integer) : integer ; begin F : = 16 * (9 - x) * (9 - x) + 127 ; end ; BEGIN a : = - 25 ; b : = 25 ; P : = 130 ; N : = 0 ; for t : = a to b do begin if (F(t) > ; P) then begin N : = N + 1 ; end ; end ; write(N) ; END.

Danil77728423 29 дек. 2020 г., 17:26:17 | 10 - 11 классы

Помогите срочно решить следующую задачу(оформить с пояснениями)?

Помогите срочно решить следующую задачу(оформить с пояснениями).

Задача : определите при каком наименьшем значении b в результате выполнения следующего алгоритма будет напечатано число 100 var a, b, t, k : integer ; function F(x : integer) : integer ; begin if x mod 2 = 0 then F : = 1 ; else F : = 0 ; end ; BEGIN a : = 100 ; readln(b) ; k : = 0 ; for t : = a to b do begin k : = k = F(t) ; end ; write(k) ; END.

На этой странице находится ответ на вопрос Записаны 2 рекурсивные функции, F и G?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.