Дано N чисел, написать программный код в паскале абц, которая находит номер самого большого числа в последовательности?

Информатика | 10 - 11 классы

Дано N чисел, написать программный код в паскале абц, которая находит номер самого большого числа в последовательности.

Ответить на вопрос
Ответы (1)
Kittychesire 20 февр. 2020 г., 18:53:24

Const N = 10 ;

var i, k, max : integer ; a : array[1.

N] of integer ;

begin Writeln('Исходные данные') ; Randomize ; for i : = 1 to N do begin k : = random(100) - 50 ; a[i] : = k ; write(k : 4) end ; writeln ; max : = - 32768 ; / / меньше не бывает for i : = 1 to N do if max < ; a[i] then max : = a[i] ; writeln('Максимальное из чисел равно ', max)

end.

Тестовый пример :

Исходные данные 39 - 42 - 3 3 - 37 - 32 25 43 24 - 17

Максимальное из чисел равно 43.

Кристинаныпийвода 30 июн. 2020 г., 21:45:37 | 10 - 11 классы

Вводится последовательность из N чисел?

Вводится последовательность из N чисел.

Найти, сколько в ней нулей и их порядковые номера.

Basic напишите программный код, пожалуйста.

Пожуйліста123 1 окт. 2020 г., 08:24:32 | 5 - 9 классы

Программный код сортировки Timsort на Паскале?

Программный код сортировки Timsort на Паскале.

Mila1996 18 июл. 2020 г., 20:22:09 | 5 - 9 классы

Написать программный код в С + + для данного примера?

Написать программный код в С + + для данного примера.

Svetlana3012642 23 дек. 2020 г., 01:36:59 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число.

Программа получает на вход целые числа, количество введенных данных неизвестно, последовательность чисел заканчивается числом 0.

На Паскале.

Angelinkafedyukina1 25 июн. 2020 г., 23:41:33 | 10 - 11 классы

Что выполняет данный фрагмент программного кода?

Что выполняет данный фрагмент программного кода?

Gevork65 8 июл. 2020 г., 03:50:21 | 10 - 11 классы

Циклы с постусловиями?

Циклы с постусловиями.

Разработать схему алгоритма и написать программный код на языке Паскаль.

Используя оператор Repeat Until.

VoinVasia 4 дек. 2020 г., 06:25:41 | 10 - 11 классы

Написать код программы в паскале для задачи : Дано натуральное число n?

Написать код программы в паскале для задачи : Дано натуральное число n.

Вычислить(см.

Картинку).

Pool658 18 июл. 2020 г., 00:28:34 | 5 - 9 классы

Написать программу в Паскале?

Написать программу в Паскале.

Даны два числа.

Меньшее из них замените полусуммой этих чисел, а большее - их произведением.

Составить блок - схему.

Tabdukhakimov1977 27 апр. 2020 г., 02:01:38 | 5 - 9 классы

Написать программный код к задаче Задача : Определите и выведите на экран сумму всех нечётных двузначных чисел?

Написать программный код к задаче Задача : Определите и выведите на экран сумму всех нечётных двузначных чисел.

Макс1242 30 авг. 2020 г., 06:54:32 | 5 - 9 классы

Помогите написать программу на языке Паскаль?

Помогите написать программу на языке Паскаль.

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

Кто правильно напишет поставлю лучшее решение!

На этой странице находится вопрос Дано N чисел, написать программный код в паскале абц, которая находит номер самого большого числа в последовательности?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.