Pascal ABC?

Информатика | 10 - 11 классы

Pascal ABC.

Помогите, пожалуйста, решить задачу!

Нарисуйте окружность такой линией, ширина которой больше радиуса.

Обведите полученную фигуру по контуру.

Ответить на вопрос
Ответы (1)
Yalovskaya 17 июл. 2020 г., 22:24:19

/ / Pascal ABC.

NET 3.

1 сборка 1256

Uses

GraphABC ;

Var

r, v : integer ;

begin

writeln('Введите радиус : ') ;

readln(r) ;

writeln('Введите ширину контура : ') ;

readln(v) ;

brush.

Style : = bsClear ;

pen.

Width : = r + 10 ;

circle(window.

Center.

X, window.

Center.

Y, r) ;

pen.

Width : = v ;

pen.

Color : = clPurple ;

circle(window.

Center.

X, window.

Center.

Y, r + (r + 10) div 2) ;

end.

Примечание :

При вводе 100 и 30 получается красиво.

Ybkeu1981 23 авг. 2020 г., 22:20:21 | 5 - 9 классы

Задача по информатике в Pascal ABC?

Задача по информатике в Pascal ABC.

AssAssInCrEeD0505 6 мая 2020 г., 02:05:14 | 10 - 11 классы

Pascal ABCМне нужна программа для ракеты, которая летит вверхПомогите, пожалуйста, если кто - то знает)?

Pascal ABC

Мне нужна программа для ракеты, которая летит вверх

Помогите, пожалуйста, если кто - то знает).

Sacho 9 июл. 2020 г., 17:17:23 | 5 - 9 классы

Составе программу которая рисует 5 окружностей голубого цвета , с центром в точке (200, 200) радиусами 30, 40 , 50 , 60 , 70 ?

Составе программу которая рисует 5 окружностей голубого цвета , с центром в точке (200, 200) радиусами 30, 40 , 50 , 60 , 70 .

Pascal ABC.

ValiahmetovaKa 13 дек. 2020 г., 08:52:59 | 10 - 11 классы

Пожалуйста помогите решить задачу на языке Pascal?

Пожалуйста помогите решить задачу на языке Pascal.

Задача 2.

Ilina170712 8 янв. 2020 г., 01:04:19 | 5 - 9 классы

Дан радиус окружности?

Дан радиус окружности.

Найти её диаметр.

(код Pascal).

Lalu 29 июн. 2020 г., 10:15:41 | 5 - 9 классы

Составить программу в Pascal ABC которая нарисует светофор и букву Р?

Составить программу в Pascal ABC которая нарисует светофор и букву Р.

Эдуард1305 26 нояб. 2020 г., 18:31:22 | 10 - 11 классы

Здравствуйте?

Здравствуйте!

Помогите пожалуйста составить код для задачи ниже на Pascal ABC.

Желательно как можно скорее!

Goodmodex 26 апр. 2020 г., 19:47:42 | 5 - 9 классы

Помогите решить задачу?

Помогите решить задачу.

Срочно!

Дана последовательность от 1 до 30 слов.

Напечатать : все слова в алфавитном порядке.

ПОЖАЛУЙСТА!

На Pascal ABC.

Дарь23 1 сент. 2020 г., 07:32:57 | 1 - 4 классы

Нарисовать в Pascal ABC окружности, от светлого к темному?

Нарисовать в Pascal ABC окружности, от светлого к темному.

Если можно, то скиньте программу.

Настяглухова 29 окт. 2020 г., 15:06:04 | 5 - 9 классы

В Pascal ABC?

В Pascal ABC.

Найдите радиус окружности если известна площадь окружности.

Перед вами страница с вопросом Pascal ABC?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.