В магазине продается мастика в ящиках по 15 кг, 17 кг, 21 кг?

Информатика | 5 - 9 классы

В магазине продается мастика в ящиках по 15 кг, 17 кг, 21 кг.

Как купить ровно 185 кг мастики, не вскрывая ящики?

Сколькими способами можно это сделать?

Напишите пожалуйста программу на языке C.

Ответить на вопрос
Ответы (1)
Ника2580 19 апр. 2020 г., 13:00:07

Program gt ;

var a, b, c, k : integer ;

begin

k : = 0 ;

for a : = 0 to 12 do

for b : = 0 to 10 do

for c : = 0 to 8 do

if(a * 15 + b * 17 + c * 21 = 185)then begin

k : = k + 1 ;

writeln(a, ' ', b, ' ', c) ;

end ;

writeln(k, ' - кол - во способов') ;

end.

185 / 15 = 12(приблеженно)

185 / 17 = 10

185 / 21 = 8

т.

Е 185 div 21 = 8 .

Выбераем все случаи и находим кол - во

так как больше 12 мастика по 15 кг нельзя(будет > ; 185)

и 10 по 17 и 8 по 21 то перечислим случаи и найдем решение где выполняется все условие.

Sidnevad 15 февр. 2020 г., 22:18:01 | 5 - 9 классы

С помощью Паскаля :1?

С помощью Паскаля :

1.

В магазине продается мастика в ящиках по 15 кг, 17 кг, 21 кг.

Как купить ровно 185 кг мастики, не вскрывая ящики?

Сколькими способами можно это сделать?

2. Ввести натуральное число N и вывести все натуральные числа, не превосходящие N и делящиеся на каждую из своих цифр.

Пример : Введите N : 15 1 2 3 4 5 6 7 8 9 11 12 15.

Parvina1977 20 авг. 2020 г., 15:46:53 | 5 - 9 классы

С четырех участков собрали соответственно 150, 350, 200 и 400кг?

С четырех участков собрали соответственно 150, 350, 200 и 400кг.

Яблок.

Собранные яблоки разложили в ящики по 25 кг.

Сколько понадобилось ящиков?

Кристя2012 4 февр. 2020 г., 05:32:01 | 5 - 9 классы

В совхозе за день собрали d кг?

В совхозе за день собрали d кг.

Винограда, из них a ц.

Оставили для школы, а остальное отправили в город в ящиках по 10 кг.

В каждом.

Сколько ящиков винограда отправили в город?

Lenoksa2001 19 авг. 2020 г., 09:47:26 | 5 - 9 классы

Фруктовый магазин продает яблоки поштучно по 5 руб?

Фруктовый магазин продает яблоки поштучно по 5 руб.

, груши по 7 руб.

, апельсины по 8 руб.

В первые два дня недели продано : понедельник - Х яблок, Y груш, Z апельсинов ; вторник - X яблок, Y груш, Z апельсинов.

Напишите программу, которая будет вычислять, на какую сумму продал магазин фруктов в каждый из этих дней и за оба дня вместе.

Нужно написать программу, помогите пожалуйста.

Vadim82330407 10 янв. 2020 г., 22:28:37 | 5 - 9 классы

Фруктовый магазин продает яблоки по АФруктовый магазин продает яблоки по А руб?

Фруктовый магазин продает яблоки по АФруктовый магазин продает яблоки по А руб.

За кг.

, груши по В руб.

За кг.

, апельсины по С руб.

За кг.

В первые два дня недели продано : понедельник - X кг.

Яблок, Y кгю груш, Z кгю Апельсинов (X, Y, Z - принимают разные значения в понедельник и во вторник).

Напишите Программу, которая будет вычислять, на какую сумму прдал магазин фруктов в каждый из этих дней и за оба дня вместе.

Настяпочемучка 26 апр. 2020 г., 18:59:55 | 5 - 9 классы

Имеется товар в ящиках по 15, 18 и 20 кг?

Имеется товар в ящиках по 15, 18 и 20 кг.

Определить, как получить 217 кг не вскрывая ящики.

Valeriaonicshe 6 мар. 2020 г., 18:16:55 | 5 - 9 классы

Программа по информатике?

Программа по информатике.

Дана масса яблок в ящике, которые надо разложить по пакетам по 3 кг в каждый.

Напишите программу, которая вычислит, сколько пакетов получится и сколько килограммов яблок останется.

Результат выведите на экран.

Darina200364 29 нояб. 2020 г., 20:08:44 | 5 - 9 классы

В магазине было шесть разных ящиков с гвоздями, массы ящиков 6, 7, 8, 9, 10, 11 кг?

В магазине было шесть разных ящиков с гвоздями, массы ящиков 6, 7, 8, 9, 10, 11 кг.

Пять из них приобрели два покупателя, причем каждому из них гвоздей досталось поровну.

Какой ящик остался в магазине?

GDGHNFLK 13 мар. 2020 г., 12:04:08 | 5 - 9 классы

Электронный почтовый ящик это?

Электронный почтовый ящик это.

Kroo 25 нояб. 2020 г., 00:21:17 | 10 - 11 классы

Напишите программу на алгоритмическом языке?

Напишите программу на алгоритмическом языке.

Магазин продает В машин по цене А руб.

За каждую.

Найдите общую выручку от продажи машин (все необходимые значения введите с клавиатуры)(Для Кумира).

Если вам необходимо получить ответ на вопрос В магазине продается мастика в ящиках по 15 кг, 17 кг, 21 кг?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.