Ребят, кто нибудь может написать программу транспонирования обычной матрицы из 9 чисел?

Информатика | 5 - 9 классы

Ребят, кто нибудь может написать программу транспонирования обычной матрицы из 9 чисел?

Заранее спасибо.

Ответить на вопрос
Ответы (2)
Кроули6556 16 окт. 2020 г., 03:24:13

Const n = 3 ;

var a : array[1.

N, 1.

N] of integer ;

i, j, c : integer ;

begin

Randomize ;

writeln('Исходная матрица : ') ;

for i : = 1 to n do begin

for j : = 1 to n do begin a[i, j] : = random(10) ; write(a[i, j] : 4) ; end ;

writeln ;

end ;

for i : = 1 to n do for j : = i + 1 to n do

beginc : = a[i, j] ; a[i, j] : = a[j, i] ; a[j, i] : = c ; end ;

writeln('Транспонированная матрица : ') ;

for i : = 1 to n do

begin

for j : = 1 to n do write(a[i, j] : 4) ;

writeln ;

end ;

end.

Пример :

Исходная матрица : 1 4 4 8 3 9 8 2 1

Транспонированная матрица : 1 8 8 4 3 2 4 9 1.

Katya1234katya1 16 окт. 2020 г., 03:24:18

/ / PascalABC.

NET 3.

1, сборка 1192 от 07.

03. 2016

begin / / инициализация var b : = MatrixRandom(3, 3, 10, 99) ; / / вывод Writeln('Исходная матрица') ; for var i : = 0 to 2 do begin for var j : = 0 to 2 do Write(b[i, j] : 3) ; Writeln end ; / / транспонирование for var i : = 0 to 2 do for var j : = i + 1 to 2 do if i< ; > ; j then Swap(b[i, j], b[j, i]) ; / / вывод Writeln('Транспонированная матрица') ; for var i : = 0 to 2 do begin for var j : = 0 to 2 do Write(b[i, j] : 3) ; Writeln end

end.

Тестовое решение :

Исходная матрица

48 30 15

38 49 19

21 15 41

Транспонированная матрица

48 38 21

30 49 15

15 19 41.

Ngztina 8 янв. 2020 г., 23:04:18 | 10 - 11 классы

В прямоугольной матрице целых чисел посчитать количество нулей, сумму отрицательных и произведение положительных?

В прямоугольной матрице целых чисел посчитать количество нулей, сумму отрицательных и произведение положительных.

Помогите написать программу).

NPnadezda 19 июн. 2020 г., 00:51:12 | 5 - 9 классы

Напишите программу подсчета произведения чисел в массиве Заранее спасибо?

Напишите программу подсчета произведения чисел в массиве Заранее спасибо!

A5s5d2a58a17 17 окт. 2020 г., 16:33:13 | 10 - 11 классы

Pascal?

Pascal.

Паскаль Написать программу змейку по матрице.

NikUFO 18 апр. 2020 г., 22:24:10 | 10 - 11 классы

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЬ?

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЬ!

Нахождение суммы чисел в матрице, ввод чисел осуществить из файла matrix.

Txt вывод на экран.

Котик123457 27 июл. 2020 г., 08:55:14 | 10 - 11 классы

Помогите написать программу в с + + составить программу обработки матрицы размерности N * M?

Помогите написать программу в с + + составить программу обработки матрицы размерности N * M.

ВЫПОЛНИТЬ программу для N = 3, M = 4.

Заполнение массива произвести с помощью датчика случайных чисел.

В программе предусмотреть вывод исходной матрицы и полученной.

По невозрастанию значений наибольших элементов строк.

( упорядочить(переставить)строк массива).

Denchik0 15 июн. 2020 г., 06:51:36 | 10 - 11 классы

Срочно нужна помощь?

Срочно нужна помощь!

( программа с + + )!

С помощью датчика случайных чисел заполнить двоичную матрицу 5х10.

Определить номер столбца с наибольшей суммой значений элементов.

Заранее спасибо за помощь спасибо большое!

( если можно скиньте скрин из этой программы с этим заданием!

).

AMNKA 22 нояб. 2020 г., 23:52:30 | 10 - 11 классы

Написать программу?

Написать программу.

В квадратной матрице найти произведение ненулевых диагональных элементов.

Солнышко390 11 янв. 2020 г., 17:32:54 | 10 - 11 классы

Помогите написать программу 17 задания)заранее спасибо))?

Помогите написать программу 17 задания)заранее спасибо)).

Murrrvika 8 сент. 2020 г., 22:35:49 | 1 - 4 классы

Помогите пожалуйста нужно написать программу на Делфи Заполнить матрицу натуральными числами l?

Помогите пожалуйста нужно написать программу на Делфи Заполнить матрицу натуральными числами l.

N * N, где N - размер матрицы.

В программе предусмотреть возможность изменения размера матрицы.

24 и 45.

Vladislavgrishin 9 нояб. 2020 г., 06:45:59 | 10 - 11 классы

Кто может написать программу, ну или хотя бы просто объяснить суть как ее сделать, заранее спасибо?

Кто может написать программу, ну или хотя бы просто объяснить суть как ее сделать, заранее спасибо!

Задана матрица С(5, 5).

Получить вектор В, каждый элемент которого равен количеству нулей, состоящих в столбце матрицы.

В С#.

Вопрос Ребят, кто нибудь может написать программу транспонирования обычной матрицы из 9 чисел?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.