Дана числовая последовательность из целых чисел, в которой каждое последующее число равно сумме трех предыдущих?

Информатика | 10 - 11 классы

Дана числовая последовательность из целых чисел, в которой каждое последующее число равно сумме трех предыдущих.

Число 0 является нулевым элементом этой последовательности.

Начальные элементы последовательности 0, 1, 1, 2, 4, 7, 13, 24, 44, 81 … Среди 35 первых элементов данной последовательности максимальное количество делителей имеет число ….

Ответить на вопрос
Ответы (1)
Natavarnakova 1 сент. 2020 г., 15:46:55

Var a1, a2, a3, s, k, max, kmax, i, j, imax : integer ;

begin

a1 : = 0 ; a2 : = 1 ; a3 : = 1 ;

kmax : = 0 ;

for i : = 4 to 35 do

begin

s : = a1 + a2 + a3 ;

a1 : = a2 ;

a2 : = a3 ;

a3 : = s ;

k : = 0 ;

for j : = 2 to s div 2 do if s mod j = 0 then inc(k) ;

if k> ; kmax thenbegin max : = s ; kmax : = k ; imax : = i end ;

end ;

writeln(imax, ' - е число = ', max, ' - ', kmax + 2, ' делителей') ;

end.

Результат :

32 - е число = 53798080 - 168 делителей.

Zaykaevm 2 июл. 2020 г., 18:34:58 | 10 - 11 классы

Помогите построить блок схему для VBA Дана последовательность целых чисел a1, …a45?

Помогите построить блок схему для VBA Дана последовательность целых чисел a1, …a45.

Получить число отрицательных элементов последовательности a1, …a35 и число нулевых элементов всей последовательности.

Про100упс 27 июл. 2020 г., 21:05:24 | 5 - 9 классы

Дана последовательность натуральных чисел, завершающаяся числом 0?

Дана последовательность натуральных чисел, завершающаяся числом 0.

Определите, какое наибольшее число подряд идущих элементов этой последовательности равны друг другу.

Gshcgh 3 июн. 2020 г., 11:27:54 | 10 - 11 классы

Даны целые числа a1, …a50?

Даны целые числа a1, …a50.

Получить последовательность b1, …, b50, которая отличается от исходной последовательности тем, что все нечетные элементы удвоены.

Babinaanastasi 1 июн. 2020 г., 02:21:24 | 10 - 11 классы

Создать процедуру на языке VBA Дана последовательность целых чисел a1, …a45?

Создать процедуру на языке VBA Дана последовательность целых чисел a1, …a45.

Получить число отрицательных элементов последовательности a1, …a35 и число нулевых элементов всей последовательности.

001rafik 11 мар. 2020 г., 06:00:33 | 10 - 11 классы

Дана последовательность не более N ненулевых целых чисел, последним числом в последовательности является 0?

Дана последовательность не более N ненулевых целых чисел, последним числом в последовательности является 0.

Ввести эту последовательность в одномерный массив и вычислить хаpактеристики .

Найти порядковые номера и сумму двух наибольших элементов.

( в Паскаль ).

LishkaJoyble 19 дек. 2020 г., 03:00:09 | 10 - 11 классы

Вводится последовательность из N положительных целых чисел?

Вводится последовательность из N положительных целых чисел.

Найти наименьшее число среди чётных элементов последовательности.

Ilyasuanov 17 апр. 2020 г., 22:47:52 | 5 - 9 классы

Элемент последовательности называется локальным максимумом, если он строго больше предыдущего и последующего элемента последовательности?

Элемент последовательности называется локальным максимумом, если он строго больше предыдущего и последующего элемента последовательности.

Первый и последний элемент последовательности не являются локальными максимумами.

Дана последовательность натуральных чисел, завершающаяся числом 0.

Определите количество строгих локальных максимумов в этой последовательности.

Формат входных данных : Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит, а служит как признак ее окончания).

Формат выходных данных : Выведите ответ на задачу.

Язык C + +.

Privet29 16 июл. 2020 г., 15:26:32 | 10 - 11 классы

Дана последовательность целых чисел?

Дана последовательность целых чисел.

Прищнак окончания ввода - число 0(элементом последовательности не считается ).

В последовательности как минимум одно число.

Написать программу, определяющую, является ли последовательность чисел возрастающей.

Если да програма должна вывести true, если нет - false.

ZlataFox 23 дек. 2020 г., 17:19:43 | 5 - 9 классы

Дана последовательность из n целых чисел?

Дана последовательность из n целых чисел.

Определить, есть ли в ней число, равное первому из этой последовательности.

Glamur3 2 окт. 2020 г., 11:01:41 | 10 - 11 классы

Дана последовательность n элементов?

Дана последовательность n элементов.

Написать программу которая прдсчитает сумму элементов этой последовательности.

На этой странице сайта размещен вопрос Дана числовая последовательность из целых чисел, в которой каждое последующее число равно сумме трех предыдущих? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.