Заменить все буквы, стоящие после "_" на такие же, но заглавные?

Информатика | 10 - 11 классы

Заменить все буквы, стоящие после "_" на такие же, но заглавные.

Паскаль.

Ответить на вопрос
Ответы (1)
БАГЕМА 20 янв. 2020 г., 22:43:03

Вроде так работает

var

s : string ;

i : integer ;

begin

readln(s) ;

write(s[1]) ;

for i : = 2 to length(s) do if s[i - 1] = '_' then write(Upcase(s[i]))else write(trim(s[i])) ; / / это в одну строчку с предыдущей

end.

Efimoveevgeniy 2 авг. 2020 г., 12:07:00 | 10 - 11 классы

Дана строка заменить все вхождения "по" на "под"?

Дана строка заменить все вхождения "по" на "под".

Написать программу на Паскале.

Егорталалаев 17 февр. 2020 г., 16:15:16 | 10 - 11 классы

Помогите пожалуйста написать программу в паскале : символы, стоящие на четных местах заменить на * ?

Помогите пожалуйста написать программу в паскале : символы, стоящие на четных местах заменить на * .

Пользоваться можно только : Pos, Insert, Delete, Length, Copy.

Yulyaermal 16 апр. 2020 г., 07:26:47 | 10 - 11 классы

Дан текст, записанный заглавными буквами?

Дан текст, записанный заглавными буквами.

Каких букв в нем больше : русских или латинских?

Паскалем надо, пжлст.

Урахара 14 нояб. 2020 г., 07:04:37 | 10 - 11 классы

Помогите, пожалуйста, написать программу на языке Паскаль?

Помогите, пожалуйста, написать программу на языке Паскаль.

Преобразовать массив таким образом, чтобы в первой его половине располагались элементы, стоявшие в четных позициях, а во второй половине - элементы, стоящие на нечетных позициях.

Alinka42 23 янв. 2020 г., 22:52:07 | 5 - 9 классы

Ввести имя, отчество и фамилию?

Ввести имя, отчество и фамилию.

Преобразовать их к формату «фамилия - инициалы».

Ввести символьную строку и заменить все буквы «а» на буквы «б» и наоборот, как заглавные, так и строчные.

Tatohka3331 29 февр. 2020 г., 04:13:41 | 10 - 11 классы

Паскаль ?

Паскаль .

Вычеркиватели.

Вычеркните из слова Х буквы, стоящие на чётных местах.

Eolorien 6 июн. 2020 г., 16:00:10 | 5 - 9 классы

1. замените слово "мама" на "папа" ( в паскале) 2?

1. замените слово "мама" на "папа" ( в паскале) 2.

Определите является ли текст перевертышем( например, как слово шалаш) (тоже паскаль).

Krupkinanataly 15 апр. 2020 г., 09:06:18 | 10 - 11 классы

Сколько различных слов можно образовать переставляя буквы с слове "Страуструп"?

Сколько различных слов можно образовать переставляя буквы с слове "Страуструп"?

Заглавные и прописные буквы считаются за одну букву.

Lhfyxer5 7 дек. 2020 г., 00:23:56 | 5 - 9 классы

ПОМОГИТЕ, ПОЖАЛУЙСТА?

ПОМОГИТЕ, ПОЖАЛУЙСТА!

ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ!

Дан текст.

Удвоить все буквы этого текста, стоящие в чётных позициях.

Diman3443 9 нояб. 2020 г., 04:48:17 | 1 - 4 классы

Какая клавиша включает режим заглавных букв?

Какая клавиша включает режим заглавных букв.

На этой странице вы найдете ответ на вопрос Заменить все буквы, стоящие после "_" на такие же, но заглавные?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.