Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале , используя простые формулы?

Информатика | 10 - 11 классы

Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале , используя простые формулы.

Ответить на вопрос
Ответы (1)
ВАдИМ27062001 27 окт. 2019 г., 17:17:39

Var a : string[20] ; st, b, i : integer ;

begin

writeln('Введите двоичное число : ') ;

readln(a) ;

st : = 1 ; b : = 0 ;

for i : = length(a) downto 1 do

begin

if a[i] = '1' then b : = b + st ;

st : = 2 * st ;

end ;

writeln(b) ;

end.

04may 4 янв. 2019 г., 02:43:50 | 5 - 9 классы

Перевести число 205 из десятичной системы счисления в двоичную, перевести число 1110001 из двоичной системы счисления в десятичную?

Перевести число 205 из десятичной системы счисления в двоичную, перевести число 1110001 из двоичной системы счисления в десятичную.

EXGTR 5 окт. 2019 г., 11:45:59 | 10 - 11 классы

Выполнить последовательный перевод данных (шестнадцатеричных) чисел в двоичную и десятичную системы счисления : АС873, Е2?

Выполнить последовательный перевод данных (шестнадцатеричных) чисел в двоичную и десятичную системы счисления : АС873, Е2.

Elena07071988 9 апр. 2019 г., 07:07:17 | 10 - 11 классы

Паскаль?

Паскаль.

Число в двоичной системе счисления, введенное пользователем программы, преобразовать в десятичное число.

Результат вывести на экран.

Nulilijana 12 окт. 2019 г., 18:30:34 | 5 - 9 классы

№1 на языке программирования Паскаль составить программу перевода из 16 - чной системы счисления в систему счисления с основанием 10?

№1 на языке программирования Паскаль составить программу перевода из 16 - чной системы счисления в систему счисления с основанием 10.

№2 Составить программу на ЯП Паскаль для перевода числа от 0 до 1000 из десятичной СС в двоичную СС.

Если введенное число не "попадает" в диапазон - уведомить об этом пользователя №3 на языке программирования Паскаль составить программу для перевода числа из 10 - чной системы счисления в систему счисления с основанием 12 или 16 (количество разрядов на ваше усмотрение).

Voznyackovandr 28 нояб. 2019 г., 10:03:32 | 5 - 9 классы

Помогите это очень срочно (перевод чисел десятичной системы счисления в двоичную, 8 - ую, 16 - ую)?

Помогите это очень срочно (перевод чисел десятичной системы счисления в двоичную, 8 - ую, 16 - ую).

Sevaseveranov 19 сент. 2019 г., 04:25:51 | 10 - 11 классы

Перевод из десятичной системы счисления в двоичную 133 степень 10?

Перевод из десятичной системы счисления в двоичную 133 степень 10.

QVANTYS 15 нояб. 2019 г., 17:58:20 | 5 - 9 классы

Напишите программу перевода двоичного числа 10101001011 в десятичную СС в Паскале АВС?

Напишите программу перевода двоичного числа 10101001011 в десятичную СС в Паскале АВС.

Igor215 1 нояб. 2019 г., 22:20:42 | 5 - 9 классы

Переводите число 71 из десятичной системы счисления в двоичную систему счисления в ответе напишите количества единиц в двоичной записи числа?

Переводите число 71 из десятичной системы счисления в двоичную систему счисления в ответе напишите количества единиц в двоичной записи числа.

SemaOJ 17 апр. 2019 г., 10:09:11 | 10 - 11 классы

Нужно написать программу на Паскале для перевода натурального числа из двоичной системы в десятичную (в двоичном числе не более 10 цифр)?

Нужно написать программу на Паскале для перевода натурального числа из двоичной системы в десятичную (в двоичном числе не более 10 цифр).

Alex3711 28 дек. 2019 г., 22:49:37 | 5 - 9 классы

Программа перевода двоичного числа 10101001011 в десятичную СС в Паскале АВС?

Программа перевода двоичного числа 10101001011 в десятичную СС в Паскале АВС.

На странице вопроса Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале , используя простые формулы? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.