Создайте целочисленный массив размерностью N?

Информатика | 5 - 9 классы

Создайте целочисленный массив размерностью N.

Введите значения элементов массивов с клавиатуры.

Выполните циклический сдвиг значений элементов массива на k позиций вправо (в сторону увеличения индексов элементов).

Выведите на экран значения элементов массива после выполнения операции циклического сдвига.

Примечание.

При циклическом сдвиге на одну позицию значение последнего элемента массива записывается в элемент с индексом 0.

Ответить на вопрос
Ответы (1)
Хinamori13 6 июн. 2020 г., 00:11:42

Var

n, k, i, i2, zn, zn2 : integer ;

a : array[1.

100] of integer ;

Begin

Readln(n, k) ;

for i : = 1 to n do Read(a[i]) ;

zn : = a[1] ;

for i2 : = 1 to k do begin

a[1] : = a[n] ;

for i : = 2 to n + 1 do

if i< ; > ; n + 1 then begin zn2 : = a[i] ; a[i] : = zn ; zn : = zn2 ; end ;

End ;

for i : = 1 to n do Write(a[i], '') ;

End.

Pigalevacat 11 февр. 2020 г., 21:12:00 | 5 - 9 классы

Массив из 40 случайных чисел, каждое из которых находится в диапазоне от - 30 до 30 :А) выведите на экран количество и индексы отрицательных элементов массива?

Массив из 40 случайных чисел, каждое из которых находится в диапазоне от - 30 до 30 :

А) выведите на экран количество и индексы отрицательных элементов массива.

Б) выведите на экран количество, индексы и значения элементов массива, кратных шести.

Дополнительно :

Выведите на экран максимальный элемент массива и его индекс.

Выведите на экран количество элементов массива, равных 7.

Alesya0501 19 апр. 2020 г., 23:12:06 | 10 - 11 классы

Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры)?

Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры).

Обнулите значения всех элементов с нечетными индексами.

Выведите значения одномерного массива в строку через пробел.

Zenks 10 мар. 2020 г., 02:56:58 | 10 - 11 классы

Найди все четные по значению элементы массива?

Найди все четные по значению элементы массива.

Вывести на экран значение элементов и их индекс.

Ввод элементов массива с клавиатуры.

Программа пишется на языке Паскаль.

Alinaiva 14 февр. 2020 г., 17:49:42 | 10 - 11 классы

Составьте программу ввода с клавиатуры элементов массива а [1?

Составьте программу ввода с клавиатуры элементов массива а [1.

10] и вывода на экран элементов с четными значениями и четными индексами.

Petrusina42 5 июл. 2020 г., 19:55:08 | 10 - 11 классы

Объявить массив размерностью N?

Объявить массив размерностью N.

Заполнить элементы массива.

Распечатать значения элементов массива.

Вывести значения в обратном порядке.

Вывести значения элементов с четными индексами.

Meawkisha 18 нояб. 2020 г., 12:02:59 | 10 - 11 классы

Задан одномерный массив N размерности N> ; 2?

Задан одномерный массив N размерности N> ; 2.

Осуществить циклический сдвиг этого массива на 2 позиции вправо.

2526006 25 авг. 2020 г., 17:41:07 | 5 - 9 классы

Заполнить массив случайными числами и выполнить циклический сдвиг элементов массива вправо на 1 элемент ?

Заполнить массив случайными числами и выполнить циклический сдвиг элементов массива вправо на 1 элемент .

Пример.

Массив : 123456 результат : 612345.

Di333 9 апр. 2020 г., 12:07:33 | 10 - 11 классы

СРОЧНО?

СРОЧНО!

Дан массив из 15 действительных чисел определить индексы элементов массива, значение которых равно значению первого элемента массива, если такого массива нет вывести соответствующее собщение на экран.

Oxra1575g 30 июл. 2020 г., 10:47:45 | 5 - 9 классы

Сдвинуть все элементы массива на одну позицию вправо (циклически)?

Сдвинуть все элементы массива на одну позицию вправо (циклически).

Последний элемент должен оказаться на месте первого.

В ПАСКАЛЕ.

НастяЕлизарова 12 сент. 2020 г., 02:22:04 | 5 - 9 классы

Составьте программу ввода с клавиатуры элементов массива а [1?

Составьте программу ввода с клавиатуры элементов массива а [1.

10] и вывода на экран элементов с четными значениями и четными индексами.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Создайте целочисленный массив размерностью N?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.