Составьте блок - схемы и программы для решения следующих задач?

Информатика | 5 - 9 классы

Составьте блок - схемы и программы для решения следующих задач.

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

· Если разность первого и последнего, превышает второе, то выведите второе число.

· Если сумма второго и третьего меньше четвертого числа, то выведите эту сумму.

· Если выполняются одновременно два перечисленных выше условия, то выведите второе число и сумму второго и третьего чисел.

· Иначе, выведите все четыре числа без изменения.

Ответить на вопрос
Ответы (1)
Lizakamykova2 24 сент. 2020 г., 07:32:34

Если смотреть с точки зрения Паскаля, то получается такая ересь :

var

x, z, c, y : real ;

begin

writeln('введитепервое число') ; readln(x) ;

writeln('введите второе число') ; readln(z) ;

.

Q : = x - y ; (разность первого и последнегочисла) ;

W : = z + c ; (сумма второго и третьего числа) ;

В случае если выполняются эти два условия

if Q > ; z then

if W < ; y then

begin

writeln(W) ;

writeln(z) ;

end

else

if Q > ; z then writeln(z)

else

ifW < ; y then writeln(W) ;

end.

Daren 16 мая 2020 г., 05:08:13 | 10 - 11 классы

Составьте программу для решения следующей задачи?

Составьте программу для решения следующей задачи.

Введите с клавиатуры два числа : А и В.

Если числа не равны, то замените каждое из них большим и выведите результаты на экран.

Если они равны, то найдите и выведите удвоенную сумму этих чисел.

TuR4Ik 15 мар. 2020 г., 02:07:43 | 5 - 9 классы

Паскаль : с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты?

Паскаль : с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.

Если сумма первого и третьего чисел отрицательна, то выведите эти два числа и их сумму.

Если выполняются одновременно два перечисленных выше условия, то выведите четыре числа без изменения.

Иначе, выведите сумму этих четырех чисел, уменьшенную в два раза.

Составьте соответствующие отладочные примеры и проверьте работу каждой программы.

Semkadenisds 22 апр. 2020 г., 23:16:49 | 10 - 11 классы

Составьте программу для решения следующей задачи?

Составьте программу для решения следующей задачи.

Введите с клавиатуры два числа : N и M.

Если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран.

Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты.

Иначе, найдите и выведите среднее арифметическое этих чисел.

Alekseioyu 7 июл. 2020 г., 22:19:44 | 5 - 9 классы

Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты?

Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты.

Если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.

Если сумма всех чисел не больше 80, то выведите только два первых числа.

Если выполняется одновременно два перечисленных выше условия, то выведите только два последних числа.

Иначе, выведите все четыре числа, увеличев их на 5.

Matematikblea 8 янв. 2020 г., 20:26:05 | 10 - 11 классы

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты?

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.

Если сумма первого и третьего чисел отрицательна, то выведите эти два числа и их сумму.

Если выполняются одновременно два перечисленных выше условия, то выведите четыре числа без изменения.

Иначе, выведите сумму этих четырех чисел, уменьшенную в два раза.

Составьте соответствующие отладочные примеры и проверьте работу каждой программы.

Enot982 30 апр. 2020 г., 20:57:28 | 10 - 11 классы

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты?

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

Если все числа не превышают 30, то выведите их удвоенное произведение.

Если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в 10 раз.

Если выполняются одновременно 2 условия, то выведите эти числа без изменения.

Иначе, выведите разность первого и последнего чисел.

Решить нужно в С или С + + Заранее спасибо!

MuraarranishanB 20 сент. 2020 г., 19:39:40 | 5 - 9 классы

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты?

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

· Если второе и четвертое числа отрицательны, то выведите их произведение.

· Если первое и третье числа больше 10, то выведите все четыре числа, увеличив их в десять раз

· Если выполняются одновременно два перечисленных выше условия, то выведите эти четыре числа без изменения.

· Иначе, выведите все четыре числа, уменьшив их в десять раз.

Составьте соответствующие отладочные примеры и проверьте работу каждой программы.

Milana0707bkru 29 июл. 2020 г., 01:49:16 | 10 - 11 классы

Введите с клавиатуры три числа : A, B и С?

Введите с клавиатуры три числа : A, B и С.

Если они не равны, то замените все числа наибольшим из них и выведите результаты на экран.

Иначе, найдите и выведите суммы квадратов этих чисел.

Kdjdjd82828 21 апр. 2020 г., 07:51:25 | 5 - 9 классы

Помогите пожалуйста решить в Паскале?

Помогите пожалуйста решить в Паскале.

Для четырех произвольных чмсел, введеных с клавиатуры, выведите на экран соответствующие результаты.

Если все числа не превышают 30, то выведите их удвоенное произведение.

Если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в 10 раз.

Если выполняются одновременно два перечисленных выше условия, то выведите эти числа без изменения.

Иначе, выведите разность первого и последнего чисел.

Составьте соответствующие отладочные примеры и проверьте работу каждой програмы.

Stucker 19 июн. 2020 г., 01:46:52 | 10 - 11 классы

Составьте блок - схему и программу для решения следующей задачи?

Составьте блок - схему и программу для решения следующей задачи.

Введите с клавиатуры два числа : к и л.

Если они положительны, то замените каждое на квадрат их суммы и выведите результаты на экран.

Если все числа отрицательны, то каждое сделайте равным наименьшему и выведите результаты.

Иначе, К приравняйте к 10, а Л - к 15 и выведите результаты.

На этой странице находится вопрос Составьте блок - схемы и программы для решения следующих задач?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.