Напишите программу пожалуйста Определить полярные координаты точки, заданные декартовыми координатами (x, y) по формулам f = arctg(x / y), r = √x ^ 2 + y ^ 2?

Информатика | 10 - 11 классы

Напишите программу пожалуйста Определить полярные координаты точки, заданные декартовыми координатами (x, y) по формулам f = arctg(x / y), r = √x ^ 2 + y ^ 2.

При вычислении угла @ необходимо учесть, что значение х может быть равно нулю, а угол может находиться в различных четвертях.

Ответить на вопрос
Ответы (1)
АнгелЗЗЗ 24 мая 2020 г., 06:06:53

$\phi=\begin {cases} arctg( \frac{y}{x}), \ x>0 \\ arctg( \frac{y}{x})+\pi, \ x<0,y \geq 0 \\ arctg( \frac{y}{x})-\pi, \ x<0,y<0 \\ \frac{\pi}{2}, \ x=0,y>0 \\ -\frac{\pi}{2}, \ x=0,y<0 \\ 0, \ x=0,y=0 \end {cases}$

procedure Polar(x, y : real ; var r, f : real) ;

begin r : = sqrt(sqr(x) + sqr(y)) ; if x = 0 then if y = 0 then f : = 0 else if y > ; 0 then f : = Pi / 2 else f : = - Pi / 2 else begin f : = arctan(y / x) ; if x < ; 0 then if y > ; = 0 then f : = f + Pi else f : = f - Pi end

end ;

{ тестовое решение }

var R, Fi : real ;

begin Polar(1, 1, R, Fi) ; Writeln('( + 1 ; + 1) - > ; (', R, ' ; ', Fi, ')') ; Polar(1, - 1, R, Fi) ; Writeln('( + 1 ; - 1) - > ; (', R, ' ; ', Fi, ')') ; Polar( - 1, 1, R, Fi) ; Writeln('( - 1 ; + 1) - > ; (', R, ' ; ', Fi, ')') ; Polar( - 1, - 1, R, Fi) ; Writeln('( - 1 ; - 1) - > ; (', R, ' ; ', Fi, ')') ; Polar(0, 1, R, Fi) ; Writeln('(0 ; + 1) - > ; (', R, ' ; ', Fi, ')') ; Polar(0, - 1, R, Fi) ; Writeln('(0 ; - 1) - > ; (', R, ' ; ', Fi, ')') ; Polar(0, 0, R, Fi) ; Writeln('(0 ; 0) - > ; (', R, ' ; ', Fi, ')') ;

end.

Тестовое решение :

( + 1 ; + 1) - > ; (1.

4142135623731 ; 0.

785398163397448)

( + 1 ; - 1) - > ; (1.

4142135623731 ; - 0.

785398163397448)

( - 1 ; + 1) - > ; (1.

4142135623731 ; 2.

35619449019234)

( - 1 ; - 1) - > ; (1.

4142135623731 ; - 2.

35619449019234)

(0 ; + 1) - > ; (1 ; 1.

5707963267949)

(0 ; - 1) - > ; (1 ; - 1.

5707963267949)

(0 ; 0) - > ; (0 ; 0).

Tohaplus 19 авг. 2020 г., 09:15:57 | 10 - 11 классы

Написать программу на Pascal, попадает ли точка с заданными координатами в область?

Написать программу на Pascal, попадает ли точка с заданными координатами в область?

VLADUSLAV1 19 авг. 2020 г., 06:49:30 | 10 - 11 классы

Напишите пож задачу?

Напишите пож задачу.

Даны две точки прямоугольной системе координат.

Напишите программу, определяющую, которая из точки находится ближе к началу координат.

Russkiy1413 31 мая 2020 г., 10:31:35 | 10 - 11 классы

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область?

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.

В ПАСКАЛЕ!

Karolina197 30 дек. 2020 г., 11:02:39 | 5 - 9 классы

Даны две точки в плоской прямоугольной системе координат?

Даны две точки в плоской прямоугольной системе координат.

Напишите программу, определяющую, которая из точек находится ближе к началу координат.

ВИКАКАКТУС 9 окт. 2020 г., 07:53:08 | 5 - 9 классы

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область?

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.

Язык Python.

Романбанан 25 февр. 2020 г., 11:12:05 | 5 - 9 классы

Три точки заданы своими координатами?

Три точки заданы своими координатами.

Определите, можно ли построить треугольник с вершинами в этих точках.

Напишите программу в Pascale.

Пожалуйста!

Ruslan20133 18 янв. 2020 г., 04:16:28 | 5 - 9 классы

Задача в паскале?

Задача в паскале.

Помогите пожалуйста.

Определите, лежит ли на осях координат точка (x, y).

Точка лежит на осях координат, когда абсцисса, или ордината точки равна нулю.

В программе вывести сообщение о том что, если точка с коорд.

(x, y) лежит на оси координат, то программа лежит на осях координат.

Составить математическую модель и блок - схему.

Kdkkdk06 4 июн. 2020 г., 02:19:52 | 5 - 9 классы

Три точки заданы своими координатами?

Три точки заданы своими координатами.

Определите, можно ли построить треугольник с вершинами в этих точках.

Составьте программу в Pascal, пожалуйста!

Mrmiki31 1 окт. 2020 г., 19:11:34 | 5 - 9 классы

Составить программу, определяющую, какой четверти декартовой системы координат принадлежит точка (x, y)?

Составить программу, определяющую, какой четверти декартовой системы координат принадлежит точка (x, y).

На входе – координаты точки, на выходе – номер четверти.

Выполнять в паскале Если точно не знаете, то не пишите.

Sashaivacshuk135 27 дек. 2020 г., 06:22:58 | 10 - 11 классы

Написать программу вычисления значений функций в заданных точках?

Написать программу вычисления значений функций в заданных точках.

Перед вами страница с вопросом Напишите программу пожалуйста Определить полярные координаты точки, заданные декартовыми координатами (x, y) по формулам f = arctg(x / y), r = √x ^ 2 + y ^ 2?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.