Дана последовательность литер, имеющая следующий вид : d1± d2 ± ?

Информатика | 10 - 11 классы

Дана последовательность литер, имеющая следующий вид : d1± d2 ± .

± dn (di цифры, n> ; 1).

Вычислить значение этой алгебраической суммы.

Ответить на вопрос
Ответы (1)
Tanneh2010 25 мая 2020 г., 16:50:40

Const cf = ['0'.

'9'] ;

var s : string ; i, sum, t, c : integer ;

begin

writeln('Vvedite posledovatelnost liter : ') ;

readln(s) ;

val(s[1], t, c) ; sum : = t ;

for i : = 2 to length(s) - 1 do begin if (s[ i ] in cf)and(s[i - 1] = ' + ')then begin val(s[ i ], t, c) ; sum : = sum + t ; end else if (s[ i ] in cf)and(s[i - 1] = ' - ')then begin val(s[ i ], t, c) ; sum : = sum - t ; end ; end ;

writeln('sum = ', sum) ;

end.

Olga050577 16 дек. 2020 г., 12:21:35 | 5 - 9 классы

Дана непустая последовательность положительный целых чисел, за которой следует 0?

Дана непустая последовательность положительный целых чисел, за которой следует 0.

Найти сумму всех четных чисел этой последовательности

Записать, как программу в паскале.

FRiik12 13 янв. 2020 г., 00:35:37 | 10 - 11 классы

Помогите пожалуйста по информатике?

Помогите пожалуйста по информатике.

Дана последовательность целых чисел а1 а2 а3.

Аn. вычислите сумму отрицательных элементов.

Гоаркристине 5 окт. 2020 г., 00:50:37 | 5 - 9 классы

Надо сделать в паскале 1)Дан одномерный массив вещественных чисел?

Надо сделать в паскале 1)Дан одномерный массив вещественных чисел.

Найти минимальный элемент массива.

2) Дана последовательность 7 чисел.

Вычислите сумму элементов данной последовательности меньших нуля.

Спасибо.

Maksim1995ivan 6 мая 2020 г., 09:27:31 | 10 - 11 классы

Дан текст?

Дан текст.

Напечатать все имеющиеся в нем цифры.

Temich142003 30 янв. 2020 г., 01:09:08 | 10 - 11 классы

3. Дана последовательность, вычислить сумму всех двузначных чисел последовательности?

3. Дана последовательность, вычислить сумму всех двузначных чисел последовательности.

Bujhmgfer 13 окт. 2020 г., 14:02:27 | 5 - 9 классы

Дана последовательность, состоящая из двух цифр?

Дана последовательность, состоящая из двух цифр?

12. К этой последовательности Незнайка решил применить такой алгоритм : 1) в конце данной последовательности дописать ее зеркальную копию ; 2) к цифрам, стоящим на четных местах, считая слева направо, прибавить по 1.

Найдите сумму четных цифр, находящихся в последовательности, получившейся после шестикратного применения алгоритма и запишите ее в ответе.

Misspavlovaol 28 нояб. 2020 г., 15:02:26 | 10 - 11 классы

Написать программу для решения следующей задачи вычислить модуль суммы отрицательных элементов числовой последовательности?

Написать программу для решения следующей задачи вычислить модуль суммы отрицательных элементов числовой последовательности.

Yashina05 11 окт. 2020 г., 16:50:16 | 10 - 11 классы

Вычислите сумму цифр в числе?

Вычислите сумму цифр в числе.

(Например, в числе 352 сумма цифр = 10).

Yrunthik33 7 авг. 2020 г., 11:42:47 | 5 - 9 классы

Вычислить значение выражения, заданного алгебраически : X2 - 7X + 6?

Вычислить значение выражения, заданного алгебраически : X2 - 7X + 6.

Zenkova929 24 июл. 2020 г., 13:36:47 | 10 - 11 классы

Pascal?

Pascal.

Дана последовательность чисел .

Вывести на экран суммы положительных и отрицательных чисел данной последовательности.

На этой странице сайта вы найдете ответы на вопрос Дана последовательность литер, имеющая следующий вид : d1± d2 ± ?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.