Дана непустая последовательность непустых слов из латинских букв, соседние слова отделены друг от друга запятой, за последним словом записана точка?

Информатика | 10 - 11 классы

Дана непустая последовательность непустых слов из латинских букв, соседние слова отделены друг от друга запятой, за последним словом записана точка.

Определить количество слов, которые начинаются с буквы "а".

Ответить на вопрос
Ответы (1)
Tixomirova061 21 июн. 2020 г., 20:03:12

Var s : string ;

function FindWord(first : integer) : integer ; / / Возвращает номер позиции правее first, где находится очередной разделитель

var i : integer ; c : char ;

begin i : = first + 1 ; Result : = 0 ; repeat c : = s[i] ; if (c = ', ') or (c = '.

') then Result : = i else i : = i + 1 until (Result > ; 0) or (c = '')

end ;

var ib, ie, k, n : integer ;

begin writeln('Введите строку, отделяя слова запятыми, в конце введите точку') ; readln(s) ; k : = 0 ; ib : = 1 ; n : = length(s) ; repeat ie : = FindWord(ib) ; if ie > ; 0 then begin if UpCase(s[ib]) = 'A' then k : = k + 1 ; ib : = ie + 1 end ; until (ie = 0) or (ie> ; = n) ; writeln('Количество слов, начинающихся с буквы "а", равно ', k)

end.

Введите строку, отделяя слова запятыми, в конце введите точку

A, roza, upala, na, lapu, azora, Antoshka, skazhi, ge, ty, del, moy, portfel.

Количество слов, начинающихся с буквы "а", равно 3.

Кицюня095 23 янв. 2020 г., 07:00:42 | 5 - 9 классы

Дана строка?

Дана строка.

Подсчитать количество слов , начинающихся с буквы Б.

ФМТ 4 окт. 2020 г., 15:12:04 | 10 - 11 классы

Дана непустая последовательность различных натуральных чисел , за которой следует 0?

Дана непустая последовательность различных натуральных чисел , за которой следует 0.

Определить порядковый номер наименьшего из них.

Olga050577 16 дек. 2020 г., 12:21:35 | 5 - 9 классы

Дана непустая последовательность положительный целых чисел, за которой следует 0?

Дана непустая последовательность положительный целых чисел, за которой следует 0.

Найти сумму всех четных чисел этой последовательности

Записать, как программу в паскале.

11sobachka 18 янв. 2020 г., 19:09:07 | 10 - 11 классы

Нужно написать на Паскале = ))Дан набор слов, разделенных точкой с запятой ( ; ), который заканчивается двоеточием ( : )?

Нужно написать на Паскале = ))

Дан набор слов, разделенных точкой с запятой ( ; ), который заканчивается двоеточием ( : ).

Определить, сколько в нем слов, заканчивающихся буквой «а».

200620062006 6 авг. 2020 г., 01:23:38 | 10 - 11 классы

Дана последовательность символов?

Дана последовательность символов.

Разбить ее на четыре последовательности : буквы русского алфавита, буквы латинского алфавита, цифры и другие символы.

Аликеся 21 авг. 2020 г., 04:01:29 | 10 - 11 классы

В паскале решите задачу : ) 1?

В паскале решите задачу : ) 1.

В строке слова разделены пробелами.

Определить на какую букву оканчивается четвертое слово в предложении.

2. Дана последовательность слов.

Напечатать те слова последовательности, которые отличны от первого слова и удовлетворяют следующему свойству : в слове нет повторяющихся букв.

Lena2014252 15 янв. 2020 г., 17:07:57 | 10 - 11 классы

Вася составляет 5 - буквенные слова, в которых есть только буквы С, Л, О, Н, причем буква С используется в слове ровно 1 раз?

Вася составляет 5 - буквенные слова, в которых есть только буквы С, Л, О, Н, причем буква С используется в слове ровно 1 раз.

Каждая из других допустимых букв может встречаться в слове любое количество раз или не встречаться совсем.

Словом считается любая допустимая последовательность букв, не обязательно осмысленная.

Сколько существует таких слов, которые может написать Вася?

Baltiimperia 12 янв. 2020 г., 01:15:38 | 10 - 11 классы

Дана непустая последовательность символов?

Дана непустая последовательность символов.

Постройте и напечатайте множество, элементами которого являются встречающиеся в последовательности цифры от “0” до “9''.

Kasaev2012 19 дек. 2020 г., 05:48:33 | 10 - 11 классы

Вася состовляет 5 - 6 буквенные слова в которых встречается только буквы А, Б, В, Г, при чём буква А появляется ровно 1 раз?

Вася состовляет 5 - 6 буквенные слова в которых встречается только буквы А, Б, В, Г, при чём буква А появляется ровно 1 раз.

Каждая из других допустимых букв может встречаться в слове любое количество раз или не встречаться совсем.

СЛОВОМ СЧИТАЕТСЯ ЛЮБАЯ ДОПУСТИМАЯ ПОСЛЕДОВАТЕЛЬНОСТЬ БУКВ, не обязательно для осмысления.

Сколько существует таких слов, которые может написать Вася.

Dimaddd 9 сент. 2020 г., 22:08:46 | 10 - 11 классы

(Pascal) Дана непустая последовательность слов из строчных латинских букв?

(Pascal) Дана непустая последовательность слов из строчных латинских букв.

Напечатать в алфавитном порядке :

1)все глухие согласные , которые не входят ни в одно нечетное слово

2)все звонкие согласные которые входят хотя бы в одно не четное слово и не входят ни в одно четное .

Помогите пожалуйста , вообще ничего не получается.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Дана непустая последовательность непустых слов из латинских букв, соседние слова отделены друг от друга запятой, за последним словом записана точка?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.