Дан одномерный массив P[n] Найти максимальный элемент и заменить его нулем?

Информатика | 10 - 11 классы

Дан одномерный массив P[n] Найти максимальный элемент и заменить его нулем.

Ответить на вопрос
Ответы (1)
Nyancat935 2 дек. 2020 г., 08:49:50

Var ar : array of integer ;

n, max, maxi, i : integer ;

begin ;

randomize ;

readln(n) ;

setlength(ar, n + 1) ;

writeln('First array : ') ;

for i : = 1 to n do

begin ; ar[i] : = random(100) ; write(ar[i] : 4) ; if ar[i]> ; max then begin ; max : = ar[i] ; maxi : = i ; end ;

end ;

ar[maxi] : = 0 ;

writeln ;

writeln('Final array : ') ;

for i : = 1 to n do

write(ar[i] : 4) ;

end.

RuSPrO 27 авг. 2020 г., 01:22:06 | 5 - 9 классы

Дан одномерный массив заменить второй элемент заданным числом ?

Дан одномерный массив заменить второй элемент заданным числом ;

Piratka22 19 февр. 2020 г., 06:16:54 | 10 - 11 классы

Одномерный массив состоит из нулей и единиц?

Одномерный массив состоит из нулей и единиц.

Заменить нули на единицы и единицы на нули в данном массиве.

Julia160875 6 июн. 2020 г., 06:56:50 | 10 - 11 классы

Одномерный массив E[11] Найти максимальный из отрицательных элементов?

Одномерный массив E[11] Найти максимальный из отрицательных элементов.

Таантя 26 сент. 2020 г., 19:41:16 | 5 - 9 классы

1. Дан одномерный массив из N элементов?

1. Дан одномерный массив из N элементов.

Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2.

Дан одномерный массив из Н элементов.

Найти среднее арифметическое положительных четных элементов данного массива.

Julia8282 3 дек. 2020 г., 11:36:00 | 5 - 9 классы

Дан одномерный массив, состоящий из N элементов?

Дан одномерный массив, состоящий из N элементов.

Найти максимальный из нечетных элементов массива.

Vika26082 4 апр. 2020 г., 16:57:47 | 5 - 9 классы

Написать программу на языке с + +дан массив вещественных чисел?

Написать программу на языке с + +

дан массив вещественных чисел.

Среди них есть равные.

Найти его первый максимальный элемент и заменить его нулем.

Aylovat40 16 окт. 2020 г., 08:55:54 | 10 - 11 классы

Дан одномерный массив из 12 чисел?

Дан одномерный массив из 12 чисел.

Элементами массива являются целые числа.

Найти максимальный элемент указанного массива.

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Angelina2016a 26 авг. 2020 г., 04:14:27 | 10 - 11 классы

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран?

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран.

На паскале.

Dasha20021707 27 июн. 2020 г., 01:25:56 | 10 - 11 классы

Дан одномерный массив, состоящий из 10 элементов?

Дан одномерный массив, состоящий из 10 элементов.

3начениями элементов массива являются целые числа, находящиеся в промежутке от - 100 до 100.

Найти максимальный из отрицательных элементов и заменить его обратной величиной.

На этой странице вы найдете ответ на вопрос Дан одномерный массив P[n] Найти максимальный элемент и заменить его нулем?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.