Помогите пожалуйста?

Информатика | 10 - 11 классы

Помогите пожалуйста.

(Напишите программу которая преобразует угол из градусной меры в радианную.

Результат выводится на экран) в pascal ABC.

Ответить на вопрос
Ответы (2)
Amirabdyrahmano1 16 янв. 2020 г., 15:35:25

Var s : real ; d : double ;

begin

Read(s) ;

d : = s * 3.

2425926 / 180 ;

write(s, ' градусов = ', d, ' радиан') ;

end.

Yuretspez 16 янв. 2020 г., 15:35:27

/ / PascalABC.

Net 3.

0, сборка 1052

var d : single ;

begin Write('Введите угол в градусах : ') ; Read(d) ; Writeln('Угол в радианах : ', DegToRad(d))

end.

Тестовое решение :

Введите угол в градусах : 57.

3

Угол в радианах : 1.

00007364807695

Вариант с формулой вместо функции : / / PascalABC.

Net 3.

0, сборка 1052

var d : single ;

begin Write('Введите угол в градусах : ') ; Read(d) ; Writeln('Угол в радианах : ', Pi * d / 180)

end.

Вариант, если не хочется использовать константу Pi : / / PascalABC.

Net 3.

0, сборка 1052

var d : single ;

begin Write('Введите угол в градусах : ') ; Read(d) ; Writeln('Угол в радианах : ', ArcTan(1) * d / 45)

end.

Вариант для тех, кто не помнит, что arctg(1) = π / 4 : / / PascalABC.

Net 3.

0, сборка 1052

const Pi = 3.

14 ;

var d : single ;

begin Write('Введите угол в градусах : ') ; Read(d) ; Writeln('Угол в радианах : ', Pi * d / 180)

end.

Тестовое решение для этого случая :

Введите угол в градусах : 57.

3

Угол в радианах : 0.

999566653357612

Как видно, из - за значения π, заданного с низкой точностью, снизилась и точность результата.

Arina464646 3 нояб. 2020 г., 06:13:30 | 10 - 11 классы

Составьте программу в Pascal ABC которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150?

Составьте программу в Pascal ABC которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150.

Спасибо заранее.

Laisrem13 8 дек. 2020 г., 23:51:41 | 10 - 11 классы

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов)?

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов).

Lollal1 16 февр. 2020 г., 13:00:11 | 10 - 11 классы

Напишите пожалуйста программу на pascal?

Напишите пожалуйста программу на pascal.

Составьте программу, которая выводит на экран сумму чисел кратных 5 - и от 30 до 60.

Цикл repeat.

Evashva 22 нояб. 2020 г., 02:20:56 | 5 - 9 классы

Составить программу, которая запрашивает предложение и выводит на экран все его буквы "и"?

Составить программу, которая запрашивает предложение и выводит на экран все его буквы "и".

Программу составить при помощи Pascal ABC.

Sabrinakotsk1 27 сент. 2020 г., 00:02:27 | 5 - 9 классы

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC?

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу, которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.

Tom2003 8 сент. 2020 г., 17:50:28 | 5 - 9 классы

Помогите с информатикой?

Помогите с информатикой!

Напишите программу которая вводит натуральное число N и выводит на экран N псевдослучайных чисел.

Запустите её несколько раз, объясните результаты опыта.

(Pascal ABC).

Kalerija 31 мая 2020 г., 10:44:10 | 1 - 4 классы

Дано целое число?

Дано целое число.

Напишите программу, которая выводит на экран последнюю букву данного числа, потом вводит её в квадрат и выводит на экран монитора результат.

Жранкель 28 февр. 2020 г., 01:03:04 | 5 - 9 классы

Составьте программу (в Pascal ABC), которая выводит на экран дату в рамке ?

Составьте программу (в Pascal ABC), которая выводит на экран дату в рамке :

Dmitrievazheny 30 авг. 2020 г., 17:29:18 | 5 - 9 классы

Составьте пожалуйста программу, которая осуществляет ввод в массив с клавиатуры размер 5 файлов в байтах ( от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты?

Составьте пожалуйста программу, которая осуществляет ввод в массив с клавиатуры размер 5 файлов в байтах ( от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты.

Результат выводится в строку.

В Pascal ABC.

Dalluk 28 окт. 2020 г., 03:16:46 | 5 - 9 классы

Циклы (for and while), помогите составить программу в Pascal ABC, пожалуйста?

Циклы (for and while), помогите составить программу в Pascal ABC, пожалуйста.

Составьте программу, которая выводит на экран количество трехзначных чисел у которых вторая цифра в два раза больше первой, а третья в два раза больше второй.

Вопрос Помогите пожалуйста?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.