Дана матрица размера M × N и целые числа K1 и K2 (1 ≤ K1 < ; K2 ≤ M)?

Информатика | 10 - 11 классы

Дана матрица размера M × N и целые числа K1 и K2 (1 ≤ K1 < ; K2 ≤ M).

Поменять местами строки матрицы с номерами K1 и K2.

Решить в Pascal.

Перед тем как выложить, проверить свое решение.

Ответить на вопрос
Ответы (1)
Leha228133 9 сент. 2020 г., 16:20:54

Var

b : array [1.

100] of integer ; a : array [1.

100, 1.

100] of integer ; i, j, n, m, k1, k2 : integer ;

begin

writeln ('Введите Кол - во строк') ;

readln (n) ;

writeln ('Введите Кол - во столбцов') ;

readln (m) ;

writeln ('Введите к1') ;

readln (k1) ;

writeln ('Введите к2') ;

readln (k2) ;

for i : = 1 to n do for j : = 1 to m do readln ( a [ i , j ]) ; writeln ('Исходный массив') ; for i : = 1 to n do

begin for j : = 1 to m do write(a[i, j] : 4) ; writeln ;

end ;

writeln ; for j : = 1 to m do b[j] : = a[k1][j] ; for j : = 1 to m do begin a[k1][j] : = a[k2][j] ; a[k2][j] : = b[j] ; end ; writeln ('Массив после операций') ; for i : = 1 to n do

begin for j : = 1 to m do write(a[i, j] : 4) ; writeln ;

end ;

end.

Ivan0403 18 февр. 2020 г., 23:52:43 | 10 - 11 классы

В матрице квадратной размером N поменять местами 1 строку со 2, 3 - ю с 4?

В матрице квадратной размером N поменять местами 1 строку со 2, 3 - ю с 4.

Помогите пожалуйста / / / / /.

Perhat 8 мар. 2020 г., 14:44:20 | 10 - 11 классы

Дана матрица м * n и целое чисто К(больше либо равно 0 и меньше либо равно М)удалитьь строку матрицы с номером К?

Дана матрица м * n и целое чисто К(больше либо равно 0 и меньше либо равно М)удалитьь строку матрицы с номером К.

Irinashorina 25 февр. 2020 г., 19:43:42 | 5 - 9 классы

Даны две квадратные матрицы А и В размером 3х3?

Даны две квадратные матрицы А и В размером 3х3.

Требуется найти С = А х В.

Составить программу нахождения числа строк матрицы А(N, N), сумма элементов у которых отрицательна.

Pascal abc.

Флора123 2 сент. 2020 г., 06:16:29 | 10 - 11 классы

1)Дана матрица размером M * N?

1)Дана матрица размером M * N.

В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N.

Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.

Использовать три процедуры (заполнение, смена, вывод).

Namakiti10 18 янв. 2020 г., 12:47:30 | 10 - 11 классы

Дана матрица L(3, 3), найти и вывести номера строк?

Дана матрица L(3, 3), найти и вывести номера строк.

, эле­менты которых одинаковы.

Вывести матрицу L по строкам.

Беата 3 февр. 2020 г., 07:10:19 | 10 - 11 классы

Дана матрица размера M × N?

Дана матрица размера M × N.

Упорядочить ее строки так, чтобы их минимальные элементы образовывали убывающую последовательность.

Pascal ABC.

Ivanchikunov 30 авг. 2020 г., 23:13:39 | 10 - 11 классы

Построить матрицу B , поменяв местами строки и столбцы в Паскале?

Построить матрицу B , поменяв местами строки и столбцы в Паскале.

Aleksanra313 30 апр. 2020 г., 23:01:24 | 5 - 9 классы

Даны две квадратные матрицы А и В размером 3х3?

Даны две квадратные матрицы А и В размером 3х3.

Требуется найти С = А х В.

Составить программу нахождения числа строк матрицы А(N, N), сумма элементов у которых отрицательна.

Pascal abc.

AWDN 29 авг. 2020 г., 10:03:38 | 5 - 9 классы

Программа на паскале матрицу размером 8 на 8 заполнить любыми случайными числами, затем поменять местами данные 1 / 4 и 4 / 4 матрицы?

Программа на паскале матрицу размером 8 на 8 заполнить любыми случайными числами, затем поменять местами данные 1 / 4 и 4 / 4 матрицы.

Calam 25 дек. 2020 г., 09:56:35 | 10 - 11 классы

Free Pascal?

Free Pascal.

2 задание, размер матрицы 10 на 10, числа рандомные.

Вопрос Дана матрица размера M × N и целые числа K1 и K2 (1 ≤ K1 &lt ; K2 ≤ M)?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.