Нужна помощь : Составить программу по которой компьютер угадает число введеное с клавиатуры (с помощью repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем?

Информатика | 5 - 9 классы

Нужна помощь : Составить программу по которой компьютер угадает число введеное с клавиатуры (с помощью repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем).

Ответить на вопрос
Ответы (1)
Bagi1205 15 нояб. 2020 г., 06:18:09

Var x, y, a : integer ;

c : boolean ;

begin

readln(x) ; {считываем}

a : = 1 ;

repeat

writeln(a, ' попытка выбор компьютера пал на - ') ;

y : = random(x) + 1 ; {задаем промежуток рандомом}

write(y) ;

if x = y {сравниваем} then c : = true ; {выходим из цикла в случае успеха}

until c ; {если с = true тогда выход из цикла, иначе крутимся дальше}

writeln('Компьютер сделал ', a, ' попыток.

') ;

end.

Более доработанная и понятная, если возникают какие - то вопросы - пиши в личку.

Achotovich 12 июл. 2020 г., 12:48:27 | 1 - 4 классы

Решили поиграть на компьютере в игре , не смогли потому что в компьютере не было ?

Решили поиграть на компьютере в игре , не смогли потому что в компьютере не было .

Для игры?

Ssha1279 28 дек. 2020 г., 04:02:35 | 10 - 11 классы

Pascal?

Pascal.

Составить программу угадывания числа, задуманное компьютером.

Регина20052005 9 мая 2020 г., 06:07:29 | 10 - 11 классы

Объясните как делать : составить программу которая сравнивает два числа введенные с клавиатуры и выводит на экран большее ?

Объясните как делать : составить программу которая сравнивает два числа введенные с клавиатуры и выводит на экран большее .

Parkirkur 21 февр. 2020 г., 18:59:56 | 5 - 9 классы

Нужно создать любую игру в программе Microsoft Office PowerPoint с помощью гиперсылок?

Нужно создать любую игру в программе Microsoft Office PowerPoint с помощью гиперсылок.

Очень нужна помощь, помогите).

Ника02102007 10 мая 2020 г., 08:46:27 | 10 - 11 классы

Составить блок - схему и программу, которая проверяет, равны ли 3 целых числа, введенных с клавиатуры?

Составить блок - схему и программу, которая проверяет, равны ли 3 целых числа, введенных с клавиатуры.

Vassa81 8 нояб. 2020 г., 03:13:16 | 5 - 9 классы

Составить программу?

Составить программу.

Вывести модуль целого числа введенного с клавиатуры.

Sahilchik82 5 мар. 2020 г., 18:40:30 | 10 - 11 классы

Составьте программу для угадывания числа от 1 до 15?

Составьте программу для угадывания числа от 1 до 15.

Число с клавиатуры можно вводить 3 раза.

В ответ на наше число реакция ПК должна быть больше, меньше, угадал.

Maria269 20 сент. 2020 г., 19:10:48 | 5 - 9 классы

Помогите решить задачу плиз по информатике Составьте программу "Угадай" ?

Помогите решить задачу плиз по информатике Составьте программу "Угадай" .

Программа задумывает случайное число в диапозоне от 0 до 99 после каждой попытки играющего угадать число программа выводит на экран одно из сообщений Больше , Меньше или Угадано .

На отгадывание числа дается 10 попыток программа завершается при выполнении одного из условий : дан правильный ответ либо все попытки исчерпаны.

Skajaz504 18 дек. 2020 г., 12:27:37 | 5 - 9 классы

Составить программу определяющую сумму цифр во введенном с клавиатуры целом числе?

Составить программу определяющую сумму цифр во введенном с клавиатуры целом числе.

Helen6595 22 сент. 2020 г., 06:21:03 | 5 - 9 классы

Составить блок схему Определить, является ли натуральное число, введенное с клавиатуры в память компьютера, четным?

Составить блок схему Определить, является ли натуральное число, введенное с клавиатуры в память компьютера, четным.

Результат показать на экране в виде сообщения («число четное», «число нечетное»).

Вы находитесь на странице вопроса Нужна помощь : Составить программу по которой компьютер угадает число введеное с клавиатуры (с помощью repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.