Объясните пожалуйста , какое слово что делает (в программирование) ?

Информатика | 5 - 9 классы

Объясните пожалуйста , какое слово что делает (в программирование) .

Программа Паскаль ABC.

Net : var n, m, head, eye : integer ; begin writeln('сколько лет вашему дракону?

') ; readln(n) ; head : = 1 ; eye : = 2 ; for m : = 2 to n do if m< ; = 100 then head : = head + 3 else head : = head + 2 ; eye : = head * 2 ; writeln('голов', head, 'глаз', eye) ; end.

Ответить на вопрос
Ответы (1)
530787l 25 янв. 2020 г., 04:58:29

Var n, m, head, eye : integer ; - объявили переменные целого типа

begin - начала программу

writeln('сколько лет вашему дракону?

') ; - вывели фразу'сколько лет вашему дракону?

' на экран

readln(n) ; - считали введенную переменную n и перевели каретку на новую строку

head : = 1 ; - присвоили значение

eye : = 2 ; - присвоили значение

for m : = 2 to n do - перебираем m от 2 до n

if m< ; = 100 then head : = head + 3 - считаем головы

else head : = head + 2 ; - счиаем головы

eye : = head * 2 ; - считаем глаза

writeln('голов', head, 'глаз', eye) ; - выводи результат

end.

Апельсинка1 11 авг. 2020 г., 07:47:54 | 5 - 9 классы

В директории находился файл index?

В директории находился файл index.

Htm. В этой директории создали папку с именем Head и переместили в нее файл index.

Htm. После этого полное имя файла стало С : \ Documents \ IE \ Head \ index.

Htm Каково полное имя директории до перемещения?

Angel2002 10 мая 2020 г., 18:06:20 | 10 - 11 классы

Помогите пожалуйста создать сайт?

Помогите пожалуйста создать сайт!

< ; HTML> ; < ; HEAD> ; < ; META http - equiv = "Content - Type"content = "text / html ; charset = windows - 1251"> ; < ; TITLE> ; Выравнивание и абзацы< ; / TITLE> ; < ; / HEAD> ; < ; BODY > ;

< ; / BODY> ; < ; / HTML> ;

Уточнение< ; B> ; < ; / B> ; Полужирный шрифт< ; I> ; < ; / I> ; Курсив< ; S> ; < ; / S> ; Зачеркнутый текст< ; U> ; < ; / U> ; Подчеркивание нужно сделать как на фото показано.

Йчуметнлщдшщгапм5689 22 авг. 2020 г., 00:02:41 | 5 - 9 классы

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END?

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END.

NyanLight 14 мая 2020 г., 04:24:44 | 10 - 11 классы

CРОЧНО ПОЖАЛУЙСТА ПОМОГИТЕ ?

CРОЧНО ПОЖАЛУЙСТА ПОМОГИТЕ !

СОЗДАТЬ 5 САЙТОВ html < ; html> ; < ; head> ; < ; title> ; < ; / title> ; < ; body> ;

< ; body back ground = "1.

Jpg'> ;

Cehueq703 2 июл. 2020 г., 16:35:11 | 5 - 9 классы

Помогите найти ошибку в коде : doctype = "html" HTML HEAD TITLE PAGE : MAPE / TITLE / HEAD BODY img src = "copy?

Помогите найти ошибку в коде : doctype = "html" HTML HEAD TITLE PAGE : MAPE / TITLE / HEAD BODY img src = "copy.

Jpg" width = "700" height = "388" usemap = "#Mape" map name = "Mape" area shape = "rect" coords = "2, 7, 3, 10" href = "Меркурий.

Html" / map / BODY / HTML.

Sonyatoropchina 24 мар. 2020 г., 12:41:52 | 10 - 11 классы

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ]?

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ].

Вот программа : program yyy ; function prost(var x : integer) : boolean ; var k, i : integer ; t : boolean ; begin t : = true ; k : = 0 ; for i : = 1 to x do begin if x mod i = 0 then k : = k + 1 ; end ; if k = 2 then t : = true else t : = false ; prost : = t end ; var n, m, i : integer ; begin writeln('1') ; readln(n) ; writeln('2') ; readln(m) ; for i : = n to m - 1 do begin if prost(i) and prost(i + 2) then writeln(i , (i + 2)) ; end ; end.

Шмекер 31 окт. 2020 г., 19:39:12 | 10 - 11 классы

Вопрос по С + + Надо было составить программу чтобы считывала текст из файла и выводила количество маленьких (4 - 8 символов) слов во всех строках текста То что придумал #include "stdafx?

Вопрос по С + + Надо было составить программу чтобы считывала текст из файла и выводила количество маленьких (4 - 8 символов) слов во всех строках текста То что придумал #include "stdafx.

H" #include #include #include #include using namespace std ; int main(int argc, _TCHAR * argv[]) { FILE * text ; char * filename = "C : \ \ Myfile.

Txt" ; char buf[101] = "" ; char commentStr[101] = "" ; if (!

(fopen_s(& ; text, filename, "r"))) { while (fgets(buf, 100 , text)) printf_s("%s", buf) ; char * pmin = NULL ; size_t pminlen = 0 ; char * head ; char * tail ; while ( * tail) { for (head = tail ; * head & ; & ; !

Isalnum( * head) ; + + head) { ; } for (tail = head ; * tail & ; & ; isalnum( * tail) ; + + tail) { ; } if (head < ; tail) { if ((pmin = = NULL) || (pminlen > ; tail - head)) ; { pmin = head ; pminlen = tail - head ; } } } if (pmin) { printf(" \ n") ; printf("min = %.

* s \ n", pminlen, pmin) ; } system("pause") ; return 0 ; } ничего не выдает в чем ошибка ( как мне кажется их тут дофига).

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Aigulmazh1 4 июн. 2020 г., 06:58:18 | 10 - 11 классы

Var : a, i, b : integer begin readln(a) ; for i : = 1 to a do if a mod i = 0 then b : = b + 1 ; if b = 2 then writeln('простое число') else writeln(' не простое число') end?

Var : a, i, b : integer begin readln(a) ; for i : = 1 to a do if a mod i = 0 then b : = b + 1 ; if b = 2 then writeln('простое число') else writeln(' не простое число') end.

Объясните пожалуйста подробно , что делает эта программа?

В чем суть ?

Буду очень благодарна).

Misfits201720 7 дек. 2020 г., 09:14:20 | 5 - 9 классы

Var s, i : integer ; begin s : = 1 ; For i : = 2 to 5 do s : = s * 2 ; write(s) ; end?

Var s, i : integer ; begin s : = 1 ; For i : = 2 to 5 do s : = s * 2 ; write(s) ; end.

Запишите значение переменной s, полученное в результате работы следующей программы на языке программирования Паскаль.

Вы находитесь на странице вопроса Объясните пожалуйста , какое слово что делает (в программирование) ? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.