ПОМОГИТЕ?

Информатика | 5 - 9 классы

ПОМОГИТЕ!

Дано целое число Х и натуральное N.

Составьте алгоритм вычисления X в N степени.

Прооверьте алгоритм трассировкой.

Напишите программу на языке Паскаль.

Ответить на вопрос
Ответы (1)
Akshnjdfnm 6 янв. 2020 г., 19:04:42

Если числа небольшие и X в N степени умещается в longint, то можно в цикле от 1 до n умножать на x

var i, x, n : integer ;

l : longint ;

begin

readln(x, n) ;

l : = 1 ;

for i : = 1 to n do

l : = l * x ;

write(l) ;

end.

Stess 12 янв. 2020 г., 00:52:56 | 5 - 9 классы

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N?

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N.

Проверьте алгоритм трассировкой.

Напишите программу на Паскале.

Arteeeemka6 11 апр. 2020 г., 16:31:01 | 10 - 11 классы

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих данного заданного числа N?

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих данного заданного числа N.

Напишите программу на Паскале.

P. S.

Тема урока - программирование циклов.

Evelina7980 9 дек. 2020 г., 18:37:38 | 5 - 9 классы

Составьте алгоритм вычисления суммы всех натуральных чисел не привышающих заданного натурального числа N?

Составьте алгоритм вычисления суммы всех натуральных чисел не привышающих заданного натурального числа N.

Проверьте алгоритм трассировкой.

Напишите программу в паскале.

79612837343 11 авг. 2020 г., 18:59:06 | 5 - 9 классы

Дано целое число Х и натуральное N?

Дано целое число Х и натуральное N.

Составьте алгоритм вычисления Х ^ n.

Проверьте алгоритм трассировкой.

Напишите программу на Паскале.

Alim535 22 февр. 2020 г., 13:37:18 | 5 - 9 классы

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N?

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N.

Напишите программу на Паскале.

Kirillpegaev 19 окт. 2020 г., 13:02:32 | 10 - 11 классы

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N?

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N.

Проверьте алгоритм трассировкой.

Напишите программу на Паскале пожалуйста помогите срочно.

Настяложкина 22 окт. 2020 г., 21:46:46 | 5 - 9 классы

Составьте алгоритм вычисления суммы всех натуральных чисел, не привышающих заданного натурального числа N ?

Составьте алгоритм вычисления суммы всех натуральных чисел, не привышающих заданного натурального числа N .

Проверьте алгоритм трассировкой.

Напишите программу в Паскале.

Надежжжжжж 13 дек. 2020 г., 19:28:04 | 5 - 9 классы

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа (для программы Паскаль)?

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа (для программы Паскаль).

Natzu 22 сент. 2020 г., 17:27:33 | 5 - 9 классы

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N?

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N.

Программу напишите на Бейсике.

Iordania 22 нояб. 2020 г., 05:49:35 | 5 - 9 классы

Помогите написать программу на Paskal?

Помогите написать программу на Paskal.

Дано целое число X и натуральное N.

Составьте алгоритм вычисления X в n степени.

На этой странице вы найдете ответ на вопрос ПОМОГИТЕ?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.