Записать в Паскаль программу которая должна запрашивать у пользователя значения углов треугольника и определять, может ли он существовать?

Информатика | 5 - 9 классы

Записать в Паскаль программу которая должна запрашивать у пользователя значения углов треугольника и определять, может ли он существовать.

Если треугольник с такими углами не существует, программа должна предложить пользователю ввести новые значения.

Если треугольник с введенными значениями углов существует, программа должна вывести на экран сообщение об этом и завершить работу

Пожалуйста, помогите!

Ответить на вопрос
Ответы (1)
Эдя2112 25 апр. 2020 г., 20:02:25

Uses Crt ;

var alpha, beta , gamma, Sum : real ;

begin

ClrScr ;

Sum : = 0 ;

repeat

WriteLn(' Ведите углы треугольника (в градусах) : ') ;

Write (' alpha = ') ; ReadLn(alpha) ;

Write (' beta = ') ; ReadLn(beta) ;

Write (' gamma = ') ; ReadLn(gamma) ;

Sum : = alpha + beta + gamma ;

If (Sum = 180) then WriteLn (' Существует!

') else Writeln (' Не существует.

') ;

WriteLn ;

until Sum = 180 ;

WriteLn(' Спасибо за работу!

') ;

ReadLn ;

end.

Losh 23 мая 2020 г., 21:25:37 | 5 - 9 классы

Напишите программу, которая вычисляет сумму квадратов чисел от 1 до N?

Напишите программу, которая вычисляет сумму квадратов чисел от 1 до N.

Число N программа должна запрашивать у пользователя.

Seitovaaika011 30 апр. 2020 г., 04:38:20 | 10 - 11 классы

Написать программу, которая запрашивает у пользователя номер дня недели и выводит одно из сообщений : «Рабочий день», «Суббота», «Воскресенье», или «Такого дня не существует»?

Написать программу, которая запрашивает у пользователя номер дня недели и выводит одно из сообщений : «Рабочий день», «Суббота», «Воскресенье», или «Такого дня не существует».

Medko 27 апр. 2020 г., 21:52:53 | 10 - 11 классы

Написать программу в Паскале?

Написать программу в Паскале.

Подсчитать сумму четных целых чисел находящихся от одного до значения введенного пользователем.

Lenaarefina 5 апр. 2020 г., 03:58:09 | 1 - 4 классы

Составить блок схему и программу запрашивающую у пользователя длины обеих катетов прямоугольного треугольника и выводящую на экран гипотезу по формуле пифагора?

Составить блок схему и программу запрашивающую у пользователя длины обеих катетов прямоугольного треугольника и выводящую на экран гипотезу по формуле пифагора.

Babystars 6 мая 2020 г., 14:41:40 | 10 - 11 классы

2) Написать программу вычисления площади треугольника, если известны длины двух сторон и величина угла между этими сторонами?

2) Написать программу вычисления площади треугольника, если известны длины двух сторон и величина угла между этими сторонами.

Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).

Вычисление площади треугольника.

Введите (через пробел) длины двух сторон (см) треугольника = 25 17 Введите величину угла между сторонами треугольника = 30 Площадь треугольника : 106.

25 кв.

См.

Pavelklesch 6 авг. 2020 г., 02:05:29 | 5 - 9 классы

Напишите программу, которая вычисляет сумму квадратов чисел от 1 до N?

Напишите программу, которая вычисляет сумму квадратов чисел от 1 до N.

Число N программа должна запрашивать у пользователя.

Nastyazavyalov1 13 дек. 2020 г., 09:07:01 | 10 - 11 классы

Составить программу которая покажет, существует ли треугольник с углами а, б и с?

Составить программу которая покажет, существует ли треугольник с углами а, б и с.

Jakonkzkz 14 дек. 2020 г., 14:01:37 | 10 - 11 классы

Написать программу нахождения Ymax , если задана функция : Y = Х2 – 100Х + 10, где Х изменяется от Хнач?

Написать программу нахождения Ymax , если задана функция : Y = Х2 – 100Х + 10, где Х изменяется от Хнач.

До Хкон.

С шагом С.

Программа должна так же выводить и значение Х, при котором Y принимает максимальное значение.

Значения Хнач.

, Хкон.

И С должны задаваться пользователем при выполнении программы.

Для организации цикла воспользуйтесь оператором While.

Iamapresent 29 окт. 2020 г., 15:02:41 | 10 - 11 классы

На паскале Разработайте программу запрашивающую у пользователя длины обеих катетов прямоугольного треугольника и выводящую на экран гипотенузу по формуле Пифагора?

На паскале Разработайте программу запрашивающую у пользователя длины обеих катетов прямоугольного треугольника и выводящую на экран гипотенузу по формуле Пифагора.

Bigibaga 17 нояб. 2020 г., 00:47:40 | 5 - 9 классы

Напишите программу, в которой пользователь вводит 3 дробных числа А В и С?

Напишите программу, в которой пользователь вводит 3 дробных числа А В и С.

Программа должна определить какое из трёх чисел максимальное( самое большое) и вывести его на экран.

Вопрос Записать в Паскаль программу которая должна запрашивать у пользователя значения углов треугольника и определять, может ли он существовать?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.