Напишите программу, которая проверяет, не приведет ли суммирование двух заданных целых чисел(Определенного типа) к переполнению?

Информатика | 10 - 11 классы

Напишите программу, которая проверяет, не приведет ли суммирование двух заданных целых чисел(Определенного типа) к переполнению.

Ответить на вопрос
Ответы (1)
Alenas04 16 сент. 2020 г., 03:53:32

Const low = - 32768 ; high = 32767 ;

Var i, j : integer ;

begin readln(i, j) ; if sign(i) * sign(j)< ; 0 then writeln('Сложение допустимо, результат ', i + j) else if i< ; 0 then if j< ; low - i then writeln('Сложение недопустимо : возникнет переполнение') else writeln('Сложение допустимо, результат ', i + j) else if j> ; high - i then writeln('Сложение недопустимо : возникнет переполнение') else writeln('Сложение допустимо, результат ', i + j)

end.

Zarina97zaza 20 апр. 2020 г., 18:38:56 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая : проверяет, есть ли в этом слове заданный символ.

4909380 9 февр. 2020 г., 00:10:51 | 10 - 11 классы

Составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел А и В к переполнению (т?

Составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел А и В к переполнению (т.

Е. к результату большему чем 32 767).

Если будет переполнение, то сообщить об этом, иначе вывести сумму этих чисел.

Oblivion2033 1 янв. 2020 г., 01:14:07 | 5 - 9 классы

Напишите программу, которая вычисляет частное от целочисленного деления двух заданных целых чисел и выводит на экран монитора результат?

Напишите программу, которая вычисляет частное от целочисленного деления двух заданных целых чисел и выводит на экран монитора результат.

Bodya999stepan 7 янв. 2020 г., 18:26:50 | 10 - 11 классы

Написать программу , которая проверяет , сколько раз введенное с клавиатуры число встречается в заданном массиве?

Написать программу , которая проверяет , сколько раз введенное с клавиатуры число встречается в заданном массиве.

Fightingbug 24 апр. 2020 г., 01:13:33 | 10 - 11 классы

Написать программу в паскале, которая проверяет проверяет по заданным трем сторонам треугольник на равносторонность?

Написать программу в паскале, которая проверяет проверяет по заданным трем сторонам треугольник на равносторонность.

Khaitboev77 18 янв. 2020 г., 06:24:51 | 5 - 9 классы

ЛЮДИ БЫСТРЕЙ ВЫРУЧАЙТЕ?

ЛЮДИ БЫСТРЕЙ ВЫРУЧАЙТЕ!

Напишите программу, которая вычисляет частное от целочисленного деления двух заданных целых чисел и выводит на экран монитора результат.

Lizun111111 3 апр. 2020 г., 04:03:21 | 10 - 11 классы

Помогите) проект суммирование, нужно написать программу?

Помогите) проект суммирование, нужно написать программу.

69DasHot69 20 нояб. 2020 г., 07:27:53 | 5 - 9 классы

Напишите программу проверяющую является сумма двух целых чисел, введённых с клавиатуры - чётной?

Напишите программу проверяющую является сумма двух целых чисел, введённых с клавиатуры - чётной.

Krasotka95 9 нояб. 2020 г., 09:10:00 | 5 - 9 классы

Напиши программу, которая вычесляет частное от целочисленного деления двух заданных целых чисел и выводит на экран монитора результат?

Напиши программу, которая вычесляет частное от целочисленного деления двух заданных целых чисел и выводит на экран монитора результат.

Nurimanovaalfi 5 дек. 2020 г., 06:23:22 | 5 - 9 классы

Составьте программу которая проверяет делится ли на 7 данное целое число n?

Составьте программу которая проверяет делится ли на 7 данное целое число n.

На этой странице сайта размещен вопрос Напишите программу, которая проверяет, не приведет ли суммирование двух заданных целых чисел(Определенного типа) к переполнению? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.