Помогите пожалуйста?

Информатика | 10 - 11 классы

Помогите пожалуйста!

СРОЧНО!

Даны три действительных числа.

Возвести в квадрат те из них, значения которых неотрицательны, и в четвёртую степень – отрицательные.

Нужно написать для Basic!

Ответить на вопрос
Ответы (1)
Илья008 6 сент. 2020 г., 18:42:36

Var a, b, c : integer ;

begin

read(a, b, c) ;

if a< ; 0

then a : = a * a * a * a

else a : = a * a ;

if b< ; 0

then b : = b * b * b * b

else b : = b * b ;

if c< ; 0

then c : = c * c * c * c

else c : = c * c ;

write (a, ' ', b, ' ', c) ;

end.

Вроде так затестируй на паскале у меня нет но суть такова вроде должна работать.

YnIcHkA 28 февр. 2020 г., 20:07:04 | 10 - 11 классы

33. Даны три действительных числа?

33. Даны три действительных числа.

Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень — отрицательные.

Написать в VBA и Дельфе.

Rasimmikayilov 20 февр. 2020 г., 17:30:03 | 10 - 11 классы

Даны три целых числа?

Даны три целых числа.

Возвести в квадрат отрицательные числа и в третью степень — положительные (число 0 не изменять).

Задачи необходимо выполнить на языке программирования C + +.

ЭйFoRиЯ 13 янв. 2020 г., 06:48:42 | 5 - 9 классы

Даны три числа возвести в квадрат те из них значения которых отрицательны?

Даны три числа возвести в квадрат те из них значения которых отрицательны.

1Kriz1 27 нояб. 2020 г., 05:48:53 | 5 - 9 классы

Написать программу на языке Паскаль?

Написать программу на языке Паскаль.

Даны три действительные числа.

Сложить те из них, значения которых не отрицательны.

Leshaalifirenk1 29 сент. 2020 г., 15:23:27 | 5 - 9 классы

Даны три действительных числа?

Даны три действительных числа.

Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - отрицательные.

Писать нужно на паскале.

Ihus 17 янв. 2020 г., 09:33:48 | 5 - 9 классы

Дано три числа А, В, С?

Дано три числа А, В, С.

Возвести в квадрат те числа которые отрицательные.

Если А< ; 0.

Муххаммед 11 июл. 2020 г., 07:06:39 | 10 - 11 классы

Даны 2 действительных числа?

Даны 2 действительных числа.

Возвести в квадрат те из них, значение которых неотрицательны.

Числа вводятся пользователям с клавиатуры.

Результат работы программы вводится на экран.

Jjj21 25 дек. 2020 г., 13:03:17 | 5 - 9 классы

Составте программу решающую следующую задачу дано число н если оно неотрицательно то возвести его в квадрат а если отрицательно то в третью степень?

Составте программу решающую следующую задачу дано число н если оно неотрицательно то возвести его в квадрат а если отрицательно то в третью степень.

Tst5SonMarSelena 10 авг. 2020 г., 16:25:34 | 10 - 11 классы

Помогите с кодом : Даны три целых числа?

Помогите с кодом : Даны три целых числа.

Возвести в квадрат отрицательные числа и в третью степень - положительные (число 0 не изменять).

Написать на C + + в Visual Studio.

CarpovaLada 4 мая 2020 г., 16:00:23 | 10 - 11 классы

Нарисуйте пожалуйста блок - схему, задача с ветвлениями?

Нарисуйте пожалуйста блок - схему, задача с ветвлениями!

Даны три действительных числа.

Возвести в квадрат те из них которые не отрицательные.

Вы открыли страницу вопроса Помогите пожалуйста?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.