Алгоритм вычисления значений функций F(n) и G(n), где n – натуральное число, задан следующими соотношениями : F(1) = 1 ; G(1) = 1 ; F(n) = F(n–1) – 2 * G(n–1), G(n) = F(n–1) + 2 * G(n–1), при n > ; ?

Информатика | 10 - 11 классы

Алгоритм вычисления значений функций F(n) и G(n), где n – натуральное число, задан следующими соотношениями : F(1) = 1 ; G(1) = 1 ; F(n) = F(n–1) – 2 * G(n–1), G(n) = F(n–1) + 2 * G(n–1), при n > ; = 2 Чему равно значение величины G(5) - F(5)?

Ответить на вопрос
Ответы (1)
Qqqqqaaaaa 16 дек. 2020 г., 05:15:10

Значение величины G(5) - F(5) равно 12.

В процессе вычисления каждая из функций вызывается по 31 разу, поэтому вычисление вручную очень утомительно.

Была составлена следующая программа, которая и выдала результат :

function G(n : integer) : integer ; forward ;

function F(n : integer) : integer ;

begin if n = 1 then F : = 1 else F : = F(n - 1) - 2 * G(n - 1)

end ;

function G(n : integer) : integer ;

begin if n = 1 then G : = 1 else G : = F(n - 1) + 2 * G(n - 1)

end ;

begin Writeln(G(5) - F(5))

end.

Stess 12 янв. 2020 г., 00:52:56 | 5 - 9 классы

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N?

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N.

Проверьте алгоритм трассировкой.

Напишите программу на Паскале.

Swetlana123 25 окт. 2020 г., 15:13:05 | 10 - 11 классы

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями F(1) = 1 F(n) = 18 - F(n–1) * (2 * n + 1), при n > ; 1 Чему равно значение функции F(5)?

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями F(1) = 1 F(n) = 18 - F(n–1) * (2 * n + 1), при n > ; 1 Чему равно значение функции F(5)?

Mautkinas 1 июн. 2020 г., 01:22:49 | 10 - 11 классы

1) Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями :F(1) = 1, F(2) = 1F(n) = F(n - 2) * (n - 1) + 2, при n > ; 2 Чему равно значение функции F(8)?

1) Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями :

F(1) = 1, F(2) = 1

F(n) = F(n - 2) * (n - 1) + 2, при n > ; 2 Чему равно значение функции F(8)?

В ответе запишите только натуральное число.

2) Алгоритм вычисления значения функции F(w), где w - натуральное число, задан следующими соотношениями :

F(1) = 3 ; F(2) = 3 ;

F(w) = 5 * F(w - l) - 4 * F(w - 2) при w > ; 2.

Чему равно значение функции F(15)?

Evelina7980 9 дек. 2020 г., 18:37:38 | 5 - 9 классы

Составьте алгоритм вычисления суммы всех натуральных чисел не привышающих заданного натурального числа N?

Составьте алгоритм вычисления суммы всех натуральных чисел не привышающих заданного натурального числа N.

Проверьте алгоритм трассировкой.

Напишите программу в паскале.

Нубик393994 11 мая 2020 г., 03:32:28 | 5 - 9 классы

Алгоритм вычисление функции Fn, где n = натуральное число, задан следующими соотношениями : F1 = 1 ; F2 = 1 ; Fn = Fn - 2 + Fn - 1 при n< ; 2 Чему равно F5?

Алгоритм вычисление функции Fn, где n = натуральное число, задан следующими соотношениями : F1 = 1 ; F2 = 1 ; Fn = Fn - 2 + Fn - 1 при n< ; 2 Чему равно F5?

Настяложкина 22 окт. 2020 г., 21:46:46 | 5 - 9 классы

Составьте алгоритм вычисления суммы всех натуральных чисел, не привышающих заданного натурального числа N ?

Составьте алгоритм вычисления суммы всех натуральных чисел, не привышающих заданного натурального числа N .

Проверьте алгоритм трассировкой.

Напишите программу в Паскале.

DashaKlimova 10 янв. 2020 г., 01:28:18 | 5 - 9 классы

Алгоритм вычесления значения функций F(n) , где n - натуральное число , задан следующими соотношениями : F(0) = 1, F(1) = 1 F(n) = F(n - 1) + 2 * F(n - 2), при n> ; 1 Чему равно значение функций F(6?

Алгоритм вычесления значения функций F(n) , где n - натуральное число , задан следующими соотношениями : F(0) = 1, F(1) = 1 F(n) = F(n - 1) + 2 * F(n - 2), при n> ; 1 Чему равно значение функций F(6)?

В ответе запишите только натуральное число.

Brat521 11 апр. 2020 г., 22:59:00 | 10 - 11 классы

Алгоритм вычисления значения функции F(n), где n - натуральное число, задан следующими соотношениями : F(1) = 1 F(n) = F(n - 1) * (3 * n - 2), при n > ; 1 Чему равно значение функции F(4)?

Алгоритм вычисления значения функции F(n), где n - натуральное число, задан следующими соотношениями : F(1) = 1 F(n) = F(n - 1) * (3 * n - 2), при n > ; 1 Чему равно значение функции F(4)?

Ziyaeva123 10 дек. 2020 г., 22:08:35 | 10 - 11 классы

Алгоритм вычисления значения функции F(n), где n — натуральное число, задан следующими соотношениями : F(n) = 1 при n ≤2 ; F(n) = F(n - 1) + 2 × F(n - 2) при n> ; 2?

Алгоритм вычисления значения функции F(n), где n — натуральное число, задан следующими соотношениями : F(n) = 1 при n ≤2 ; F(n) = F(n - 1) + 2 × F(n - 2) при n> ; 2.

Чем прямо значение функции F(7)?

V ответе запишите только натуральное число.

Ника995 21 дек. 2020 г., 02:32:45 | 5 - 9 классы

Алгоритм вычисления значения функции F(n), где n — натуральное число, задан следующими соотношениями : F(n) = 2 при n ≤ 2 ; F(n) = F(n − 1) + 3 · F(n − 2) при n > ; 2?

Алгоритм вычисления значения функции F(n), где n — натуральное число, задан следующими соотношениями : F(n) = 2 при n ≤ 2 ; F(n) = F(n − 1) + 3 · F(n − 2) при n > ; 2.

Чему равно значение функции F(5)?

В ответе запишите только натуральное число.

Вы зашли на страницу вопроса Алгоритм вычисления значений функций F(n) и G(n), где n – натуральное число, задан следующими соотношениями : F(1) = 1 ; G(1) = 1 ; F(n) = F(n–1) – 2 * G(n–1), G(n) = F(n–1) + 2 * G(n–1), при n &gt ; ?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.