Передавая записку на уроке английского языка, друзья не хотят, чтобы кто - то прочел ее содержимое?

Информатика | 5 - 9 классы

Передавая записку на уроке английского языка, друзья не хотят, чтобы кто - то прочел ее содержимое.

Для этого текст шифруют простым методом : заменяют каждую букву на букву, расположенную в алфавите на расстоянии N символов от исходной.

Считается, что алфавит циклически замкнут.

Напишите программу - шифровальщик.

Ответить на вопрос
Ответы (1)
Рита14041997 30 авг. 2020 г., 07:28:43

Const N = 5 ; EN = 'abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ' ; RU = 'абвгдеёжзийклмнопрстуфхцчшщьыъэюяАБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЬЫЪЭЮЯ' ;

Var S : String ; i : Byte ;

Begin Readln(S) ; For i : = 1 to Length(S) do Begin If Pos(S[i], EN)> ; 0 then If Pos(S[i], EN) + N< ; = Length(EN) then S[i] : = EN[Pos(S[i], EN) + N] else S[i] : = EN[Pos(S[i], EN) + N - Length(EN)] ; If Pos(S[i], RU)> ; 0 then If Pos(S[i], RU) + N< ; = Length(RU) then S[i] : = RU[Pos(S[i], RU) + N] else S[i] : = RU[Pos(S[i], RU) + N - Length(RU)] ; end ; Writeln(S) ;

end.

Alimbek0202 1 мая 2020 г., 03:16:07 | 5 - 9 классы

Шифр Цезаря"?

Шифр Цезаря".

Этот шифр реализует следующее преобразование текста : каждая буква исходного текста заменяется третьей после нее буквой в алфавите, который считается написанным по кругу.

Расшифруйте слово нултхсёуглв.

Tanyasha40 2 февр. 2020 г., 04:59:04 | 10 - 11 классы

Шифр Цезаря"?

Шифр Цезаря".

Этот шифр реализует следующее преобразование текста : каждая буква исходного текста заменяется третьей после нее буквой в алфавите, который считается написанным по кругу.

Используя этот шифр, зашифруйте слова ИНФОРМАТИКА , ДАННЫЕ, ТЕХНОЛОГИЯ.

Виктория1456 4 февр. 2020 г., 06:53:43 | 1 - 4 классы

Шифр Цезаря - один из самых простых и известных методов шифрования, в котором каждый символ в тексте заменяется символом, находящимся на некотором постоянном числе позиций левее или правее него в алфа?

Шифр Цезаря - один из самых простых и известных методов шифрования, в котором каждый символ в тексте заменяется символом, находящимся на некотором постоянном числе позиций левее или правее него в алфавите.

Например, слово КОНКУРС, зашифрованное шифром Цезаря со сдвигом 3, выглядит как НСРНЦУФ.

Сколько гласных букв в исходном сообщении, которое в зашифрованном виде со сдвигом 4 записано как ДПЖТФМЦР?

А Б В Г Д Е Ё Ж З И Й К Л М Н О П Р С Т У Ф Х Ц Ч Ш Щ Ъ Ы Ь Э Ю Я.

Sandy1ne 22 мар. 2020 г., 12:11:04 | 5 - 9 классы

Этот шифр реализует следующее преобразования текста каждая буква исходного текста заменяется третьей после неё буквой в алфавите которой считается по кругу?

Этот шифр реализует следующее преобразования текста каждая буква исходного текста заменяется третьей после неё буквой в алфавите которой считается по кругу.

Используя этот шифр зашифруйте слова календарь ученик атлантика.

Danil210500 24 окт. 2020 г., 11:58:49 | 10 - 11 классы

Шифр преобразует текст так, что каждая исходная буква заменяется второй после неё буквой в алфавите, который считается написанным по кругу?

Шифр преобразует текст так, что каждая исходная буква заменяется второй после неё буквой в алфавите, который считается написанным по кругу.

Используя шифр закодируйте слово работа.

Gasikqwe 13 окт. 2020 г., 03:12:12 | 10 - 11 классы

Сколько информации в тексте , если он состоит из трёх страниц по 8 строк на каждой и в каждой строке по 10 символов , если алфавит состоит из 16 - ти букв ( символов)?

Сколько информации в тексте , если он состоит из трёх страниц по 8 строк на каждой и в каждой строке по 10 символов , если алфавит состоит из 16 - ти букв ( символов).

Uraaaaaa 26 окт. 2020 г., 00:00:25 | 5 - 9 классы

"Шифр Цезаря"?

"Шифр Цезаря".

Этот шифр реализует следующее преобразование текста : каждая буква исходного текста заменяется третьей после неё буквой в алфавите, который считается написанным по кругу.

Используя этот шифр, расшифруйте слово НУЛТХСЁУГЧЛВ.

Максим2006год 1 июл. 2020 г., 14:37:49 | 1 - 4 классы

Зная , что каждая буква исходного текста заменяется третьей после нее буквойв алфавите русского языка , который считается записным по кругу , декодируйте следующие высказывания И?

Зная , что каждая буква исходного текста заменяется третьей после нее буквойв алфавите русского языка , который считается записным по кругу , декодируйте следующие высказывания И.

В. Шишкана : < ; br / > ; ЗЖЛРФХЕЗРРЮП ТСДЦЙЖЗРЛЗП Н ХУЦЖЦ ДЮОГ СЖРГ - ЗЖЛРФХЕЗРРГГВ ОБДСЕЯ Н УСЖЛРЗ.

Linad228 21 дек. 2020 г., 17:02:16 | 5 - 9 классы

Помогите, до понедельника?

Помогите, до понедельника.

Зная, что каждая буква исходного текста заменяется 3 после нее буквой в алфавите русского языка которой считается записанным по кругу, декорируйте следующие сообщения :

Жуцёг льл, г ргмжиыя - дзузёл.

Фхгуюм жуцё оцъыз рсеюш жецш.

Tankooo199 25 дек. 2020 г., 23:47:01 | 1 - 4 классы

Код ЦезаряДекодируй указанное сообщение : еугйжг рз жзогзх жсдуг Обратите внимание?

Код Цезаря

Декодируй указанное сообщение : еугйжг рз жзогзх жсдуг Обратите внимание!

Каждая буква исходного текста заменяется третьей после неё буквой в алфавите русского языка, который считается записанным по кругу!

Вы зашли на страницу вопроса Передавая записку на уроке английского языка, друзья не хотят, чтобы кто - то прочел ее содержимое?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.