Найдите количество целых чисел на интервале [100 ; 25000], у которых сумма цифр в десятичной и пятеричной системах счисления одинаковые?

Информатика | 10 - 11 классы

Найдите количество целых чисел на интервале [100 ; 25000], у которых сумма цифр в десятичной и пятеричной системах счисления одинаковые.

В ответе укажите целое число без пробелов и знаков препинания, например, 19.

Ответить на вопрос
Ответы (1)
Vetasmotovelov1 3 окт. 2020 г., 03:42:06

Vara, b : array [100.

25000] of integer ;

i, k, n, p : integer ;

Begin

for i : = 100 to 25000 do begin b[i] : = i ; a[i] : = i ; n : = 0 ; while a[i]> ; 0 do begin n : = n + (a[i] mod 10) ; a[i] : = a[i]div 10 ; end ; p : = 0 ; while b[i]> ; 0 do begin p : = p + (b[i] mod 5) ; b[i] : = b[i]div 5 ; end ; if(n = p) then inc(k) ; end ; writeln(k) ;

end.

GLV307 28 апр. 2020 г., 04:29:36 | 5 - 9 классы

Найдите минимальное основание позиционной системы счисления X, такое, что если число 37X, записанное в этой системе счисления, перевести в десятичную систему счисления – итог будет равен результату во?

Найдите минимальное основание позиционной системы счисления X, такое, что если число 37X, записанное в этой системе счисления, перевести в десятичную систему счисления – итог будет равен результату возведения числа 2 в некоторую целую степень.

В ответе укажите целое число.

Kristiska 31 янв. 2020 г., 16:19:12 | 5 - 9 классы

Укажите максимальное трёхразрядное число, представимое в системе счисления с основанием 2?

Укажите максимальное трёхразрядное число, представимое в системе счисления с основанием 2.

В ответе укажите только число без каких - либо знаков препинания.

Например, 100.

1011121314151 6 дек. 2020 г., 06:36:38 | 5 - 9 классы

Переведите целые числа из десятичной системы счисления в восьмиричную ?

Переведите целые числа из десятичной системы счисления в восьмиричную :

Zaa1809 19 авг. 2020 г., 01:46:05 | 5 - 9 классы

Переведите целые числа из десятичной системы счисления в восьмеричную : а) 513 ; б) 600 ; в) 2010 Переведите целые числа из десятичной системы счисления в шестнадцатеричную : а) 513 ; б) 600 ; в) 2010?

Переведите целые числа из десятичной системы счисления в восьмеричную : а) 513 ; б) 600 ; в) 2010 Переведите целые числа из десятичной системы счисления в шестнадцатеричную : а) 513 ; б) 600 ; в) 2010.

Berdenovaa 22 дек. 2020 г., 18:41:04 | 5 - 9 классы

Переведите целые числа из десятичной системы счисления в шестнадцатеричную ?

Переведите целые числа из десятичной системы счисления в шестнадцатеричную :

Zurmat2004 8 июн. 2020 г., 02:00:28 | 1 - 4 классы

Сумма чисел 20 и 15 в пятеричной системе счисления будет равно скольким?

Сумма чисел 20 и 15 в пятеричной системе счисления будет равно скольким.

Shulgacarin 23 нояб. 2020 г., 06:23:43 | 5 - 9 классы

Записать алгоритм вычитания столбиком целых чисел в десятичной системе счисления?

Записать алгоритм вычитания столбиком целых чисел в десятичной системе счисления.

Nikolenkodiana1 6 дек. 2020 г., 20:42:35 | 10 - 11 классы

Записать цифры пятеричной системы счисления?

Записать цифры пятеричной системы счисления?

Timurmilcev 4 янв. 2020 г., 05:05:49 | 5 - 9 классы

Записать алгоритм вычитания столбиком целых чисел в десятичной системе счисления?

Записать алгоритм вычитания столбиком целых чисел в десятичной системе счисления.

Thanksfor 5 апр. 2020 г., 21:05:57 | 5 - 9 классы

Запишите наименьшее трехзначное число в пятеричной и троичной системах счисления и переведите эти числа в десятичную систему счисления?

Запишите наименьшее трехзначное число в пятеричной и троичной системах счисления и переведите эти числа в десятичную систему счисления.

На этой странице сайта размещен вопрос Найдите количество целых чисел на интервале [100 ; 25000], у которых сумма цифр в десятичной и пятеричной системах счисления одинаковые? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.