Задача PascalНайти наименьшие элементы в каждом столбце матрицы Х(5, 5) и переписать их в одномерных массив А?

Информатика | 10 - 11 классы

Задача Pascal

Найти наименьшие элементы в каждом столбце матрицы Х(5, 5) и переписать их в одномерных массив А.

В массиве А вычислить сумму элементов, стоящих на четных местах и произведение элементов, стоящих на нечетных местах.

Массив А, сумму и произведение вывести на экран.

Ответить на вопрос
Ответы (1)
Surinmish 8 янв. 2020 г., 16:03:55

Program n1 ;

Uses CRT ;

Const n = 5 ;

Var x : array[1.

N, 1.

N] of integer ; a : array[1.

N] of integer ; i, p, s, j : integer ;

begin

ClrScr ;

Randomize ;

For i : = 1 to n do For j : = 1 to n do x[i, j] : = random(100) ;

j : = 1 ;

Repeat

For i : = 1 to n do If a[j]< ; x[i, j] then a[j] : = x[i, j] ;

write(a[j] : 4) ;

j : = j + 1 ;

Until j = n + 1 ;

p : = 1 ;

writeln ;

For i : = 1 to n do If i mod 2 = 0 then s : = s + a[i] else p : = p * a[i] ;

writeln('Proizvedenie = ', p, ', Summa = ', s) ;

readln

end.

Bara2 25 нояб. 2020 г., 00:50:39 | 10 - 11 классы

Найти сумму элементов стоящих на четных местах и элементов стоящих на нечетных местах в массиве : 3, 7, - 2, 11, 6, - 3, 91, - 74, 10?

Найти сумму элементов стоящих на четных местах и элементов стоящих на нечетных местах в массиве : 3, 7, - 2, 11, 6, - 3, 91, - 74, 10.

Ephemeral 14 июл. 2020 г., 02:29:23 | 5 - 9 классы

Составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов, формирует и выводит на экран в строку данный массив?

Составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов, формирует и выводит на экран в строку данный массив.

Найти сумму неположительных элементов массива, количество элементов кратных 3, произведение элементов, стоящих на четных местах.

Hatashaprudhik 4 авг. 2020 г., 01:37:25 | 10 - 11 классы

Дан целочисленный одномерный массив из n - элементов?

Дан целочисленный одномерный массив из n - элементов.

Вывести на экран четные элементы стоящие на нечетных массивов через паскаль.

Abk83 16 мая 2020 г., 19:21:28 | 5 - 9 классы

В одномерном целочисленном массиве из 10 элементов1?

В одномерном целочисленном массиве из 10 элементов

1.

Найдите количество отрицательных элементов с четными номерами.

2. Найдите произведение элементов, стоящих после 0.

Массив нулем не заканчивается.

В Pascal.

Надежда19841 23 июл. 2020 г., 09:17:50 | 10 - 11 классы

Дан одномерный массив целых чисел?

Дан одномерный массив целых чисел.

Найти сумму всех четных элементов массива, стоящих на четных местах (имеющих четные номера).

Массив задается с помощью генератора случайных чисел.

Если можно с блок - схемой.

Vsesnaychaia 11 июн. 2020 г., 02:46:50 | 10 - 11 классы

Найти сумму элементов массива H(11) , стоящих на четных местах и их количество?

Найти сумму элементов массива H(11) , стоящих на четных местах и их количество.

Fgjhkkhg 4 февр. 2020 г., 17:16:13 | 10 - 11 классы

С + + одномерный массив из 15 элементов нужно посчитать сумму положительных элементов массива и произведение отрицательных элементов и узнать что больше сумма или произведение?

С + + одномерный массив из 15 элементов нужно посчитать сумму положительных элементов массива и произведение отрицательных элементов и узнать что больше сумма или произведение.

Polishok17 13 нояб. 2020 г., 02:05:29 | 5 - 9 классы

В массиве F(15) найти сумму элементов, стоящих на нечетных местах?

В массиве F(15) найти сумму элементов, стоящих на нечетных местах.

Seregaarhipov20 23 окт. 2020 г., 02:59:02 | 5 - 9 классы

Задан двумерный массив В из 4 - х строк и 5 - и столбцов?

Задан двумерный массив В из 4 - х строк и 5 - и столбцов.

Составить программу, которая организует одномерный массив, каждый элемент которого есть сумма элементов в столбце.

Вычислить произведение элементов полученного массива.

Shippi546 9 дек. 2020 г., 21:39:18 | 5 - 9 классы

1)В одноменрном массиве найит разность наибольшего и наименьшего элемента?

1)В одноменрном массиве найит разность наибольшего и наименьшего элемента.

2)Дан одномерный массив.

Вывести на экран числа >5

3)В одномерном массиве найти произведение нулевых элементов.

Вы открыли страницу вопроса Задача PascalНайти наименьшие элементы в каждом столбце матрицы Х(5, 5) и переписать их в одномерных массив А?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.