Одна из составных частей бензинового двигателя имеет форму валика?

Информатика | 10 - 11 классы

Одна из составных частей бензинового двигателя имеет форму валика.

Для измерения толщины валика служит стальная плита , в которой в ряд выстроены 15 отверстий с точно уствновленными размерами.

Каждое последующее отверстие имеет диаметр несколько больше предыдущего.

Калибровка валика заключается во вкладывании его в отверстие ; если он не помещается , то его диаметр считат больше диаметра отверстия , а если помещается, то меньше .

Таким образом диаметр валика определяется достточно точно.

Рабочие , которым поручена калибровка, пробуют каждый валик не более чем на четырех отверстиях.

Какова очередность этих проб?

Ответить на вопрос
Ответы (1)
Il2003koza 21 мая 2020 г., 23:11:00

Известный метод артиллерийской вилки, когда пристреливаются по принципу "перелет - недолет".

Пусть отверстия пронумерованы от 1 до 15.

Сначала пробуем отверстие №8 (посередине ряда).

Если валик не помещается, следующим пробуем середину участка 8 - 15, т.

Е. отверстие №12.

А если проваливается - то середину участка 1 - 8, т.

Е. отверстие №4.

Далее, по аналогии, пробуем середину отрезка левее или правее сделанной пробы, т.

Е. отверстия с четными номерами.

И четвертая проба будет контрольной - отверстие с нечетным номером.

Контрольная - потому что место валика и так уже понятно.

Proninahelen75 8 июн. 2020 г., 08:18:52 | 5 - 9 классы

Решить задачу : В узком и очень длинном желобе находятся 8 шариков, четыре синих слева и четыре красных чуть - чуть большего диаметра справа?

Решить задачу : В узком и очень длинном желобе находятся 8 шариков, четыре синих слева и четыре красных чуть - чуть большего диаметра справа.

В средней части желоба в стенке имеется небольшая ниша, в которой может поместиться один синий или один красный шарик.

Два любых шарика могут расположиться рядом поперек желоба только в том месте, где находиться ниша.

Левый конец желоба закрыт, а в правом конце есть отверстие, через которое может пройти синий шарик, но не может пройти красный.

Вынимать шарики из желоба не разрешается.

Как выкатить из желоба все синие шарики?

Raffaello1 30 мар. 2020 г., 13:38:17 | 10 - 11 классы

4. 52?

4. 52.

Вася пытается высунуть голову в форточку размерами a и b см.

Приняв ус - ловно, что его голова — круглая диаметром d см, определить, сможет ли Вася сделать это.

Для прохождения головы в форточку необходим зазор в 1 см с каждой стороны.

4. 53.

Даны вещественные положительные числа a, b, c, x, y.

Выяснить, пройдет ли кирпич с ребрами a, b, c в прямоугольное отверстие со сторонами x и y.

Про - совывать кирпич в отверстие разрешается только так, чтобы каждое из его ре - бер было параллельно или перпендикулярно каждой из сторон отверстия.

4. 54.

Пассажир должен был сдать в камеру хранения пустой чемодан в форме па - раллелепипеда размерами 1a , 2 a и 3a см и коробку размерами 1b , 2b и 3b см.

Оплачивать нужно каждый размещаемый предмет.

Определить, сможет ли пассажир сэкономить на оплате, поместив коробку в чемодан так, что стороны чемодана и коробки будут параллельны либо перпендикулярны друг другу.

Anastasiaana 15 янв. 2020 г., 19:12:18 | 5 - 9 классы

Даны положительные числа a, b, c?

Даны положительные числа a, b, c.

Выяснить пройдёт ли кирпич с рёбрами "a", "b", "c" в квадратное отверстие со стороной x.

P. S.

Алгоритм с ветвлением.

15hocleist 5 мая 2020 г., 09:42:25 | 10 - 11 классы

Pascal ABC?

Pascal ABC.

Составьте программу, которая рисует деталь в виде кольца внешним радиусом 150 и внутренним радиусом 50, в котором вырезаны отверстия радиусом 30.

Их центры находятся на расстоянии 100 от центра кольца (число отверстий n вводится с клавиатуры).

2< ; n< ; 8.

НастяГордашевская 23 мар. 2020 г., 10:01:24 | 10 - 11 классы

Имеется N количество шариков?

Имеется N количество шариков.

Для каждого шарика известен диаметр.

Определить количество шариков с диаметром < ; 5 см.

Ruspolit 25 окт. 2020 г., 05:57:06 | 10 - 11 классы

Задача нужна на С + + ?

Задача нужна на С + + .

Определить, может ли кирпич, имеющий форму прямоугольного параллелепипеда с ребрами а, в, с, пройти через квадратное отверстие со стороной d, если да, то какой стороной (а - в, в - с или а - с).

Задача нужна на С + +.

Ubu68 6 мар. 2020 г., 14:47:31 | 10 - 11 классы

Определите, может ли кирпич, имеющий форму прямоугольного параллелепипеда с ребрами a, b, c, пройти через прямоугольное отверстие со сторонами x и y(при этом стороны параллелепипеда параллельны сторон?

Определите, может ли кирпич, имеющий форму прямоугольного параллелепипеда с ребрами a, b, c, пройти через прямоугольное отверстие со сторонами x и y(при этом стороны параллелепипеда параллельны сторонам отверстия).

Считать, что при равенстве размеров отверстия и кирпича кирпич не сможет пройти в отверстие.

Мурадин2000 7 февр. 2020 г., 13:07:25 | 1 - 4 классы

Составить блок схему и программу к следующей задачи?

Составить блок схему и программу к следующей задачи.

Дана квадратная пластина с прямоугольным отверстием .

Известно сторона А = 50, а стороны С = 5 и В = 10.

Найти заштрихованную площадь.

ОльгаЮрьевна1 18 дек. 2020 г., 21:57:01 | 5 - 9 классы

Помогите с Информатикой (Программирование на языке PascalABC?

Помогите с Информатикой (Программирование на языке PascalABC.

Net).

Нужно создать программу .

Вычислите площадь кольца Введите исходные данные Радиус кольца - > ; 3.

5 Радиус отверстия (см) - > ; 7 Ошибка!

Радиус отверстия не может быть - Кольца S = PR ^ 2.

Kristynochka2015 14 нояб. 2020 г., 08:38:57 | 5 - 9 классы

Пожалуйста?

Пожалуйста!

Очень нужна помощь!

Дана задача

Заданы размеры А, В прямоугольного отверстия и размеры Х, Y, Z кирпича.

Определить пройдет ли кирпич через отверстие.

Вот решение, нужно его написать без crt

Program z2_37 ;

Uses crt ;

Label 1 ;

var m, a, b, x, y, z : real ;

Begin Clrscr ; Write ('Размеры отверстия a, b = ') ; Read(a, b) ; Write ('Размеры кирпича x, y, z = ') ; Read(x, y, z) ; if a>b then begin m : = a ; a : = b ; b : = m end ; if x>y then begin m : = x ; x : = y ; y : = m end ; if x>z then begin m : = x ; x : = z ; z : = m end ; if y>z then begin m : = y ; y : = z ; z : = m end ; if (x> = a) or (y> = b) then write('Кирпич не пройдет через отверстие') else write('Кирпич пройдет через отверстие') ;

1 : Readkey ;

end.

Вопрос Одна из составных частей бензинового двигателя имеет форму валика?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.