Помогите решить, сколько сможете?

Информатика | 5 - 9 классы

Помогите решить, сколько сможете!

(Паскаль) 1)Дано целое четырехзначное число.

Выяснить, является ли оно палиндромом, то есть таким числом,

десятичная запись которого читается одинаково слева направо и справа налево.

2)Дано целое трехзначное число.

Определить, равен ли квадрат этого числа сумме кубов его цифр.

3)Дано целое трехзначное число.

Определить есть ли среди его цифр одинаковые 4)Дано целое четырехзначное число.

Определить, равна ли сумма двух его первых цифр сумме двух его последних цифр.

5) Даны три целых числа.

Определить, имеется ли среди них хотя бы одна пара равных между собой чисел.

Формат входных данныx Входной файл содержит три целых числа через пробел.

Формат выходных данныx Выведите 'YES' если это так, и 'NO' в противном случае.

Ответить на вопрос
Ответы (1)
Shakirenok 28 апр. 2020 г., 19:12:06

Задача 1

Program Zadanie1 ;

var i, N : integer ;

A : array[1.

4]of integer ;

Begin

readln(n) ;

A[1] : = round(int(N / 1000)) ;

A[2] : = round(int(N / 100)) - A[1] ;

A[3] : = round(int(N / 10)) - A[1] - A[2] ;

A[4] : = N - A[1] - A[2] - A[3] ;

if (A[1] : = A[4]) and (A[2] : = A[3]) and (A[3] : = A[2]) and (A[4] = A[1]) then writeln('полином') ;

end ;

Задача 2

Program Zadanie2 ;

var i, N : integer ;

A : array[1.

3]of integer ;

function Kub(a) : integer ; begin Kub : = a * a * a ; end ;

Begin

readln(n) ;

A[1] : = round(int(N / 1000)) ;

A[2] : = round(int(N / 100)) - A[1] ;

A[3] : = N - A[1] - A[2] - A[3] ;

if N * N = kub(A[1]) + kub(A[2]) + kub(A[3]) then writeln('равенство') ;

end ;

Oskoklkovaalyona 18 мар. 2020 г., 11:21:10 | 5 - 9 классы

Определите, чему будет равна сумма всех целых чисел от единицы до заданного числа N?

Определите, чему будет равна сумма всех целых чисел от единицы до заданного числа N.

Входные данные Первая строка содержит целое число N (1 < ; = N < ; = 100).

Выходные данные Выведите одно целое число — сумму чисел от 1 до N.

Эдвардик 3 авг. 2020 г., 13:26:54 | 5 - 9 классы

Дано целое положительное четырехзначное число?

Дано целое положительное четырехзначное число.

Напишите программу, позволяющую определить сумму двух первых цифр и разность двух последних цифр.

Nastenkasergee 11 сент. 2020 г., 21:40:15 | 10 - 11 классы

Программу на Си?

Программу на Си.

Найти все трехзначные числа, сумма цифр которых равна данному целому числу.

Fatik41 21 мар. 2020 г., 13:20:24 | 10 - 11 классы

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу?

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу.

(pascal).

Levashova2004 24 февр. 2020 г., 14:59:01 | 10 - 11 классы

Дано целое число N?

Дано целое число N.

Определите, кратна ли числу К сумма цифр в числе.

Мухтар7 11 авг. 2020 г., 21:59:02 | 5 - 9 классы

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые?

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые.

Клубничка311 29 дек. 2020 г., 21:54:23 | 5 - 9 классы

Дано натуральное трёхзначное число n?

Дано натуральное трёхзначное число n.

Найдите сумму и произведение цифр в нём.

Формат входных данных

Вводится целое число n (100≤n≤999)

Формат выходных данных

Требуется вывести сумму и произведение его цифр через пробел.

Цунаде 25 дек. 2020 г., 17:36:17 | 5 - 9 классы

Задача C?

Задача C.

Делители Дано целое число N.

Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < ; = N < ; = 10 ^ 12) Формат выходных данных Выведите ответ к задаче.

RiatQ 8 нояб. 2020 г., 03:43:20 | 5 - 9 классы

Даны целое число k и последовательность цифр «10111213?

Даны целое число k и последовательность цифр «10111213.

9899», в которой выписаны подряд все двузначные числа.

Определите k - ю цифру в последовательности.

Формат входных данных Вводится одно целое число kk (1≤k≤1801≤k≤180).

Формат выходных данных Требуется вывести искомую цифру.

Kisaa00101 10 нояб. 2020 г., 04:12:57 | 5 - 9 классы

Даны два целых числа от 1 до 1 000 000 000?

Даны два целых числа от 1 до 1 000 000 000.

Найти сумму этих чисел.

Входные данные : два целых числа.

Выходные данные : целое число.

На Паскале.

На этой странице вы найдете ответ на вопрос Помогите решить, сколько сможете?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.