Написать псевдокод (или блок схему) и код программы для решения следующей задачи : Вычислить среднее арифметическое для чисел, вводимых с клавиатуры?

Информатика | 10 - 11 классы

Написать псевдокод (или блок схему) и код программы для решения следующей задачи : Вычислить среднее арифметическое для чисел, вводимых с клавиатуры.

Результат вывести на экран.

Ответить на вопрос
Ответы (1)
197212345 8 июн. 2020 г., 07:50:19

Uses crt ;

var a, sum, k : integer ; sr : real ;

begin sum : = 0 ; k : = 0 ; writeln('Вводите числа.

0 - конец последовательности') ; repeat readln(a) ; sum : = sum + a ; inc(k) ; until a = 0 ; writeln(sum / (k - 1)) ;

end.

Zinenko05 20 сент. 2020 г., 13:25:24 | 10 - 11 классы

Написать программу для решения следующей задачи : Имеется массив чисел, вводимый с клавиатуры?

Написать программу для решения следующей задачи : Имеется массив чисел, вводимый с клавиатуры.

Вычислить сумму и произведение всех чисел массива.

Результаты вывести на экран.

Язык c + + .

Спасибо.

Aruwdi 19 февр. 2020 г., 16:00:17 | 10 - 11 классы

С клавиатуры вводится 10 произвольных чисел?

С клавиатуры вводится 10 произвольных чисел.

Составить блок - схему и программу определения суммы всех вводимых чисел.

Masюля 2 февр. 2020 г., 10:54:15 | 5 - 9 классы

Написать программу которая находит среднее арифметическое пяти целых нечетных чисел, вводимых с клавиатуры?

Написать программу которая находит среднее арифметическое пяти целых нечетных чисел, вводимых с клавиатуры.

Maksimabdulin 1 мар. 2020 г., 04:23:08 | 10 - 11 классы

Написать код программы для решения следующей задачи : Дано 5 чисел?

Написать код программы для решения следующей задачи : Дано 5 чисел.

Посчитать произведение максимального и минимального чисел для данного подмножества.

Результат вывести на экран.

Язык программирования C + +.

Анар051434 22 сент. 2020 г., 13:54:22 | 5 - 9 классы

Напишите программу находящую среднее арифметическое четных чисел, вводимых с клавиатуры?

Напишите программу находящую среднее арифметическое четных чисел, вводимых с клавиатуры.

Задачу решить с помощью цикла с параметром.

MadFox 24 авг. 2020 г., 15:42:24 | 10 - 11 классы

Написать программу, которая вводит с клавиатуры последовательность из 10 вещественных чисел, считает сумму и среднее арифметическое этих чисел?

Написать программу, которая вводит с клавиатуры последовательность из 10 вещественных чисел, считает сумму и среднее арифметическое этих чисел.

Нужно сделать для этой задачи блок - схему : - ) : - ) : - )заранее спасибо.

Katia991 9 июл. 2020 г., 06:02:55 | 10 - 11 классы

Вести n чисел и найти среднее арифметическое?

Вести n чисел и найти среднее арифметическое.

Написать программу и нарисовать блок схему.

Ogromania 1 сент. 2020 г., 17:16:52 | 10 - 11 классы

Написать программу для решения следующей задачи : найти среднее арифметическое наибольшего и наименьшего элементов данной конечной числовой последовательности?

Написать программу для решения следующей задачи : найти среднее арифметическое наибольшего и наименьшего элементов данной конечной числовой последовательности.

+ блок - схема.

Только блок - схему!

Firestar03 22 авг. 2020 г., 14:31:14 | 5 - 9 классы

Составьте программу, которая запрашивает три целых числа и, если ни одно из чисел не равно нулю, выводит на экран их среднее арифметическое?

Составьте программу, которая запрашивает три целых числа и, если ни одно из чисел не равно нулю, выводит на экран их среднее арифметическое.

Нарисуйте блок - схему алгоритма решения этой задачи.

ИраИлюхина2006 16 дек. 2020 г., 20:49:45 | 5 - 9 классы

Помогите, пожалуйста, написать программы?

Помогите, пожалуйста, написать программы!

Очень нужно!

Язык - паскаль!

1) вычислить количество введенных с клавиатуры чисел.

Окончанием служит ввод значения x.

2) вывести максимальное из чисел, вводимых с клавиатуры.

Окончанием служит ввод значения x.

3) вывести произведение 20 чисел вводимых с клавиатуры.

4) вычислить произведение чисел, вводимых с клавиатуры.

Окончанием служит ввод значения x.

На странице вопроса Написать псевдокод (или блок схему) и код программы для решения следующей задачи : Вычислить среднее арифметическое для чисел, вводимых с клавиатуры? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.