Выполнить переворот или сортировку массива с помощью процедур(pascal abc)?

Информатика | 5 - 9 классы

Выполнить переворот или сортировку массива с помощью процедур(pascal abc).

Ответить на вопрос
Ответы (1)
Бексултан1111 8 апр. 2020 г., 23:28:42

Const nm = 100 ;

type Mas = array[1.

Nm] of integer ;

procedure Shell(var a : Mas ; n : integer) ;

{ сортировка методом Шелла }

var i, j, step, t : integer ;

begin step : = n div 2 ; while step > ; 0 do begin for j : = n - step downto 1 do begin i : = j ; while i < ; = n - step do begin if a[i] > ; a[i + step] then begin t : = a[i] ; a[i] : = a[i + 1] ; a[i + 1] : = t end ; i : = i + step end end ; step : = step div 2 end

end ;

var x : Mas ; i, n : integer ;

begin Randomize ; Write('Введите число элементов в массиве (1 - 100) : ') ; Readln(n) ; Writeln('Исходный массив') ; for i : = 1 to n do begin x[i] : = Random(101) - 50 ; Write(x[i] : 4) end ; Shell(x, n) ; Writeln(#13#10, 'Отсортированный массив') ; for i : = 1 to n do Write(x[i] : 4)

end.

Тестовое решение :

Введите число элементов в массиве (1 - 100) : 20

Исходный массив - 8 - 17 - 19 1 - 3 23 - 33 30 - 27 - 45 12 26 - 24 18 37 8 47 - 14 - 19 - 3

Отсортированный массив - 45 - 33 - 27 - 24 - 19 - 19 - 17 - 14 - 8 - 3 - 3 1 8 12 18 23 26 30 37 47.

Slender2774 30 янв. 2020 г., 19:21:30 | 10 - 11 классы

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ?

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ!

Задан целочисленный массив из 10 случайных целых чисел.

Выполнить сортировку элементов массива, стоящих на четных номерах по убыванию методом пузырька.

АlexеY 5 авг. 2020 г., 14:15:35 | 10 - 11 классы

Отсортировать в двумерном массиве целых случайных чисел чётные столбцы методом сортировки прямого выбора?

Отсортировать в двумерном массиве целых случайных чисел чётные столбцы методом сортировки прямого выбора.

Sokolova77eko 10 окт. 2020 г., 21:58:09 | 10 - 11 классы

Какое минимальное количество тестов потребуется для проверки процедуры сортировки одномерного массива?

Какое минимальное количество тестов потребуется для проверки процедуры сортировки одномерного массива?

Milana2003m 20 нояб. 2020 г., 19:20:06 | 5 - 9 классы

Составить программу на Паскале сортировки массива по возрастанию?

Составить программу на Паскале сортировки массива по возрастанию.

Андрей30062002 2 июн. 2020 г., 16:39:27 | 10 - 11 классы

Сортировка данных?

Сортировка данных.

Алгоритм прямого обмена при сортировке массива.

Луиза561 26 янв. 2020 г., 15:25:57 | 10 - 11 классы

Составить алгоритм и программу сортировки массива по возрастанию методом извлечения?

Составить алгоритм и программу сортировки массива по возрастанию методом извлечения.

Бес4 13 июн. 2020 г., 06:17:03 | 10 - 11 классы

Дан массив целых чисел?

Дан массив целых чисел.

Пользователь вводит с экрана кол - во элементов в массиве.

Элементы в массиве генерируются случайно (диапазон чисел от - 100 до + 100).

Отсортировать исходный массив с помощью различных алгоритмов сортировки.

C + +.

Chislin2013 24 нояб. 2020 г., 13:42:51 | 10 - 11 классы

Объединить два случайным образом созданных массива в один упорядочить новый массив по убыванию Pascal ABC по теме : сортировка массива?

Объединить два случайным образом созданных массива в один упорядочить новый массив по убыванию Pascal ABC по теме : сортировка массива.

SVT1508 20 дек. 2020 г., 01:12:11 | 10 - 11 классы

Используя обменную сортировку, отсортировать массив по убыванию в динамическом массиве в паскале?

Используя обменную сортировку, отсортировать массив по убыванию в динамическом массиве в паскале.

Terminator007 7 окт. 2020 г., 20:16:51 | 5 - 9 классы

Видоизмените программу сортировки массива выбором так чтобы в ней использовалась процедура выбора наибольшего элемента массива?

Видоизмените программу сортировки массива выбором так чтобы в ней использовалась процедура выбора наибольшего элемента массива.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Выполнить переворот или сортировку массива с помощью процедур(pascal abc)?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.