В упорядоченный по возрастанию числовой массив из 15 элементов вставить числа - 2 и 5, не нарушая упорядоченности?

Информатика | 10 - 11 классы

В упорядоченный по возрастанию числовой массив из 15 элементов вставить числа - 2 и 5, не нарушая упорядоченности.

Ответить на вопрос
Ответы (1)
Kitty2392001 26 авг. 2020 г., 00:17:53

Const n = 15 ;

type ArrayOfInteger = array [1.

N + 2] of integer ;

procedure ArrayOutput(A : ArrayOfInteger ; a_length : integer) ;

var i : integer ;

begin for i : = 1 to a_length do write(A[i] : 4, ' ') ; writeln ;

end ;

procedure ArraySort(var A : ArrayOfInteger ; a_length : integer) ;

var i, j, temp : integer ;

begin for i : = 1 to a_length - 1 do for j : = i + 1 to a_length do if A[i]> ; A[j] then begin temp : = A[i] ; A[i] : = A[j] ; A[j] : = temp ; end ;

end ;

var mass : ArrayOfInteger ; i : integer ;

begin writeln('Программа упорядочивает массив по возрастанию ') ; writeln('и вставляет числа - 2 и 5, не нарушая упорядоченности.

') ;

{Создаём массив} randomize ; for i : = 1 to n do mass[i] : = random(100) - 50 ; writeln('Начальный массив : ') ; ArrayOutput(mass, n) ; ArraySort(mass, n) ; writeln('Отсортированный массив : ') ; ArrayOutput(mass, n) ;

{Добавляем к массиву числа - 2 и 5 и сортируем полученный массив} mass[n + 1] : = - 2 ; mass[n + 2] : = 5 ; ArraySort(mass, n + 2) ;

{Выводим итоговый массив} writeln('Упорядоченный массив : ') ; ArrayOutput(mass, n + 2) ;

end.

Barabashka120 1 окт. 2020 г., 23:19:12 | 10 - 11 классы

Дан массив b (n) ?

Дан массив b (n) .

Переписать в массив C(n) отрицательные элементы массива b(n) умноженные на 4.

Затем упорядо­чить методом «пузырька» по возрастанию новый массив.

Найти общее количество одинаковых элементов в упорядоченном массиве.

БеспаловаУльяна555 20 мар. 2020 г., 12:46:59 | 10 - 11 классы

Задана матрица В(n, m)?

Задана матрица В(n, m).

Определить количество столбцов, упорядоченных по возрастанию.

Каждый второй столбец упорядочить по возрастанию и найти, на сколько увеличилось количество таких упорядоченных столбцов.

( в паскале решить).

Valensiya200 1 сент. 2020 г., 20:26:16 | 5 - 9 классы

Написать алгоритм упорядочения расположения чисел n1 n2 n3 вводимых в программу по возрастанию?

Написать алгоритм упорядочения расположения чисел n1 n2 n3 вводимых в программу по возрастанию.

Kankulieva 2 апр. 2020 г., 05:35:13 | 10 - 11 классы

Паскаль?

Паскаль.

Задано массив целых чисел упорядочений по убыванию А(1 ; n) и число В.

Для числа В найти такое место среди элементов массива А , чтоб после вставки числа В на это место упорядоченность массива не нарушалась.

Если впоследствии равенства между собою значений элементов массива А число может вставляться на разные места, то следует выяснить самое близкое к началу массива место.

Anastasiа 22 мая 2020 г., 07:13:23 | 10 - 11 классы

Блок схему построить?

Блок схему построить.

Дан массив x размера n(n = 10) целых чисел, содержащий как положительные, так и отрицательные элементы.

Упорядочить массив следующим образом : сначала идут отрицательные числа, упорядоченные по невозрастанию, потом положительные, упорядоченные по неубыванию.

Nastya123456789012 10 февр. 2020 г., 17:53:28 | 10 - 11 классы

Даны два вектора {хi}, {уi}, i = 1, ?

Даны два вектора {хi}, {уi}, i = 1, .

10, упорядоченные по возрастанию.

Соединить их в один вектор {zi}, i = 1, …, 20, так чтобы сохранилась упорядоченность.

На Паскале .

Прошу само решение, а не советы.

Abdulvobova 13 февр. 2020 г., 01:55:39 | 10 - 11 классы

Помогите решить вторую?

Помогите решить вторую.

1. Даны три числа а, b, с.

Удвойте эти числа, если они являются упорядоченными по возрастанию.

2. Проверьте, есть ли среди трех заданных чисел равные.

Кристинаагилеровна 24 авг. 2020 г., 07:24:06 | 5 - 9 классы

Составить программу, которая составит из двух таблиц 3 - ю, упорядоченную по возрастаннию?

Составить программу, которая составит из двух таблиц 3 - ю, упорядоченную по возрастаннию.

В паскале.

Nykin29 13 дек. 2020 г., 23:20:01 | 5 - 9 классы

Даны два массива А и В, упорядоченные по возрастанию?

Даны два массива А и В, упорядоченные по возрастанию.

Слить эти два массива в один, также упорядоченный по возрастанию.

Kirichenko1995 2 янв. 2020 г., 11:38:58 | 5 - 9 классы

Упорядоченое множество однотипных элементов которым можно присвоить общее имя различающихся индексами?

Упорядоченое множество однотипных элементов которым можно присвоить общее имя различающихся индексами.

На этой странице вы найдете ответ на вопрос В упорядоченный по возрастанию числовой массив из 15 элементов вставить числа - 2 и 5, не нарушая упорядоченности?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.